Urgent command frozen

Discussion in 'Electronics' started by popes11, Apr 16, 2014.

  1. popes11

    popes11 Hardcore MB Enthusiast

    Messages:
    137
    Joined:
    Feb 5, 2014
    Car:
    r class
    On holiday at the moment and my command on a 2007 r class is frozen. From memory it is version 2.5. The command screen in stuck on the audio screen. None of the button on the command unit are responding. Basically I can't do anything with it. I was depending on the sat nav to get me around and basically don't have clue when it comes to roads in the area I am in. Four kids in the back are not helping. Anyone know how I can reset the unit.
     
  2. chrisdean

    chrisdean Hardcore MB Enthusiast

    Messages:
    368
    Joined:
    Mar 17, 2014
    Location:
    Liverpool
    Car:
    W205 C200 AMG Line Premium
    Disconnect the battery for a couple of minutes might give it the chance to reboot.
     
  3. V12

    V12 MB Club Veteran

    Messages:
    5,610
    Joined:
    Jun 17, 2002
    Location:
    Southampton
    Car:
    S320CDI LWB
    Pull the fuse is the easier option.
     
  4. OP
    OP
    popes11

    popes11 Hardcore MB Enthusiast

    Messages:
    137
    Joined:
    Feb 5, 2014
    Car:
    r class
    I was thinking of pulling the power via fuse or Bat. Few pints in me
    now after a hard day at Legoland. Anyone know where my fuse box is?
     
  5. nigel cross

    nigel cross Hardcore MB Enthusiast

    Messages:
    2,410
    Joined:
    Jan 8, 2005
    Location:
    Surrey
    Car:
    W164 ML350 Audi S4
    If its like a ML then it will be in the rear above the offside rear wheel.
    They look a real mess,as Prince Phillip once said' looks like this wiring was done by a bunch of Indians'
     
  6. richard

    richard Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    5,561
    Joined:
    Jun 10, 2002
    Location:
    Berkshire, UK
    Car:
    MY04 SL55, MY17 GLC250d AMG Sport
    If your going to disconnect battery (after a few points) remember to disconnect only the ground (keeping spanner away from live), leave it a min, and then re-connect. On Mercedes, ground is BROWN. Positive is Red.
     
  7. OP
    OP
    popes11

    popes11 Hardcore MB Enthusiast

    Messages:
    137
    Joined:
    Feb 5, 2014
    Car:
    r class
    Can I cause myself any further problems by disconnecting the bat? Don't want to make my problem any worse. Thanks for replys.
     
  8. Alfie

    Alfie Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    7,245
    Joined:
    May 5, 2004
    Location:
    Surrey
    Car:
    W169 A class (loaded)
    No. ITs a simple process and you should be fine.
     
  9. AMGeed

    AMGeed MB Club Veteran

    Messages:
    9,155
    Joined:
    Nov 1, 2008
    Location:
    Bournemouth/Poole Dorset
    Car:
    2004 W211 E55K ///AMG
    It has been known for the ESP light to illuminate after disconnecting the battery. This happened recently when I replaced my E55 battery. Turning the steering from lock to lock a couple of times cleared it.
    Also, windows may have to be reset.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.