Urgent - Locked out of my C55

Discussion in 'Electronics' started by tudu, Oct 16, 2008.

  1. tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    I locked my car as normal last night and have just gone to open with the remote - won't work neither will my spare remote. Anyone any ideas?
     
  2. timskemp

    timskemp Hardcore MB Enthusiast

    Messages:
    3,090
    Joined:
    Dec 9, 2006
    Location:
    Hull
    Car:
    W213 E220d
    unlock it with the key?
     
  3. A-AvantGarde

    A-AvantGarde Hardcore MB Enthusiast

    Messages:
    4,639
    Joined:
    Nov 11, 2003
    Location:
    South Bucks
    Car:
    2016 BMW F86 X6 M, 2016 BMW F30 320d, 2001 Mercedes C320 Elegance
    Does it look like the car battery is dead? As you've tried both keys I assume that they are okay (check that the red light comes on the key when you hold the button for a few seconds)

    Have you tried to open the car using the blade element of the key?
     
  4. glojo

    glojo MB Club Veteran

    Messages:
    14,144
    Joined:
    Sep 15, 2004
    Location:
    Torquay
    Car:
    S211 Sprinter 213CDI, & the new T-class
    Has the blade resolved your issue if not then have you got the Mobilo number?


    008001777 7777

    Good luck
    Regards
    John
     
  5. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    Thanks all. Managed to get it open but have to put the key right next to the sensor on the drivers door handle - strange as its a new key remote only had it 3 weeks. Seems both work i.e. red light comes on but nothing happens unless as i said above have to put the remote almost next to the sensor. Could it be batteries? can understand on one the older remote but not the new one.
     
  6. A-AvantGarde

    A-AvantGarde Hardcore MB Enthusiast

    Messages:
    4,639
    Joined:
    Nov 11, 2003
    Location:
    South Bucks
    Car:
    2016 BMW F86 X6 M, 2016 BMW F30 320d, 2001 Mercedes C320 Elegance
    Sounds like you've got a problem with the radio element of the system. The W203 can also unlock using IR (which sounds like what is happening here). Think there's an aerial or amp that the radio element of the unlock utilises.

    I was an early adopter of the new style Chrome key but sourced mine from the US (who use a different radio frequency). My chrome key only works in a way similar to the way you describe, i.e. using IR but not Radio. Can you try moving a little further away from the car (but remain in sight of the drivers the door handle) and try lock / unlock to help prove my theory. E.g. my Chrome key won't unlock from the passenger side or the front of the vehicle, so I still use my original keys almost all the time!
     
  7. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    The new chrome remote was supplied by MB Exeter, but the original remote does the same thing, only works about 6 inches away from the sensor.
     
  8. Rory

    Rory MB Club Veteran

    Messages:
    7,240
    Joined:
    Mar 12, 2005
    Location:
    Cheshire, UK
    Car:
    C270CDi Estate (late 2004 facelift model)
    Drive the car and try it somewhere else - it *might* just be radio interference.

    However prob more likely to be a car problem (unlikely to be key if both do the same).
     
  9. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    Just got back from a 20 minute drive - parked up. Car locked and unlocked but still had to stand right next to the drivers door. Will get it checked out at MB Plymouth in the morning as i was hoping to leave for London first thing.
     
  10. andy27168

    andy27168 Hardcore MB Enthusiast

    Messages:
    4,324
    Joined:
    Nov 27, 2004
    Location:
    Southampton
    Car:
    1997 C230K, 1999 C43/55 AMG
    Hi,
    I think if it was my C43 I would try disconnecting/reconnecting the battery, In my understanding effectively rebooting the electronics of the car, worth a try and costs nothing.
     
  11. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    Thanks. But not really happy to try that might make matters worse. Wont i loose all my star codes etc?
     
  12. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)

    Just a thought. I was working in HMP Exeter today, and had to pass through a security scanner about 8 times. The bling remote was in my pocket. Could that have been a cause for the problem?
     
  13. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    I thought it started yesterday. I doubt the scanner caused it but I don't they pass objects like that round the scanner normally.? Not sure as I normally avoid prison..:rolleyes: ;)
     
  14. A210AMG

    A210AMG MB Club Veteran

    Messages:
    8,475
    Joined:
    Mar 15, 2007
    Location:
    England
    Hello

    The scanner you mentioned 'could' be the problem?

    A few years ago my dad went over to Germany to collect a car (another marque) and stayed in a hotel, went to pay after 3 or 4 days and none of his cards worked.

    Not one, something somehow had made them unusable. He's away again at the mo otherwise I would ask him. It casued a real pain as you can imagine not having a huge amount of euros.

    So it could be similar?
     
  15. A-AvantGarde

    A-AvantGarde Hardcore MB Enthusiast

    Messages:
    4,639
    Joined:
    Nov 11, 2003
    Location:
    South Bucks
    Car:
    2016 BMW F86 X6 M, 2016 BMW F30 320d, 2001 Mercedes C320 Elegance
    Think it's quite likely to be the aerial / antenna that receives the radio signal from the car or some interference at the location you were at. I doubt that the scanner or anything else has caused the problem with your key.

    I think a member on here had a similar problem a while back, although I think his was caused by some modding after replacing the rear SAM. Like I say I believe there are two ways of operation for the key IR & Radio. My theory is that yours is only working on IR at the moment.

    To confirm my theory have you tried unlocking from the other side or the front of the vehicle?
     
  16. OP
    OP
    tudu

    tudu Hardcore MB Enthusiast

    Messages:
    1,203
    Joined:
    Jan 2, 2008
    Location:
    Plymouth, Devon
    Car:
    05 C200K Sport Edition (Kleemann)
    Just got back from London. Took car into MB Exeter on Friday afternoon on the way. MB reckon because i have had the windows tinted it has interfered with the radio signal, so probably need new antenna (under the headlining) 3 hour job. I can only open the car from the drivers side but it takes a good few tries on the remote (pressing key red light comes on) even to get it to open that way as well. Took about 5 mins to get it to open after i had parked at a service station on the way back - right pain in the neck. My C200K has the same window tint and i have never had any problems with the remote even though it was done well over a year ago. Strange that one works and the C55 doesn't.
     
  17. st13phil

    st13phil MB Club Veteran

    Messages:
    7,330
    Joined:
    Nov 6, 2007
    Location:
    North Oxfordshire
    Car:
    His - Denim Blue A220 AMG Line Premium / Hers - Obsidian Black R172 SLK55
    That doesn't smell right to me. I know this may sound daft, but upen all the windows then try locking / unlocking with the key fob. If it works OK then maybe the dealer's right. If not, then I smell BS...
     
  18. glojo

    glojo MB Club Veteran

    Messages:
    14,144
    Joined:
    Sep 15, 2004
    Location:
    Torquay
    Car:
    S211 Sprinter 213CDI, & the new T-class
    I was going to suggest something similar and have maybe the doors open.

    We saw Jeremy Clarkson put the remote to his head and that increased the range so maybe a flimsy coating of tint might decrease it??

    Good luck anyway
    Regars
    John
     
  19. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,400
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    just sit in the car and try..
     
  20. A-AvantGarde

    A-AvantGarde Hardcore MB Enthusiast

    Messages:
    4,639
    Joined:
    Nov 11, 2003
    Location:
    South Bucks
    Car:
    2016 BMW F86 X6 M, 2016 BMW F30 320d, 2001 Mercedes C320 Elegance
    Doesn't sound right to me either, I've got tints on mine and that doesn't cause any problems with my lock / unlocking.

    I can't see any way in which a window tint could effect radio signals anyway.
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.