V Class Electronic Parking Brake

Page may contain affiliate links. Please see terms for details.

Wearsthefoxhat

MB Enthusiast
Joined
Feb 10, 2019
Messages
1,086
Location
Sunny south coast
Car
SL500 : R129. /. E55k : S211
The EPB is showing up as a fault, yellow and red icons. The EPB operates as I can hear the motors and see the cables move.
In “workshop” mode, the “ replace brake pads” option tells me that the EPB is inoperative which is fine.

The question is, does this option only release the EPB or does it also drive back the other brake pistons to aid replacement ???
Is there anything else that could fool me in replacing all pads, front, rear and parking. Presume that the parking brake pads are similar to the old hub style ones.. tia..
 
The only way you will know what the cause is is to plug it in and see the codes and do a strip of the discs, pads and shoes to see what the issue is. Often the cables snap on these.
 
The only way you will know what the cause is is to plug it in and see the codes and do a strip of the discs, pads and shoes to see what the issue is. Often the cables snap on these.
Thank you. Both cables appear to be fine, they both move when the EPB is operated but the cable seems to bend, flex, not a straight pull back so maybe something inside is amiss. There is a lot of brake dust on the wheel bolt ends too.
codes are C101B00 ( B or 8, bad writing..) brake power not reached and C101500. Mechanical fault..
I shall have a look and let you all know.
 
Thank you. Both cables appear to be fine, they both move when the EPB is operated but the cable seems to bend, flex, not a straight pull back so maybe something inside is amiss. There is a lot of brake dust on the wheel bolt ends too.
codes are C101B00 ( B or 8, bad writing..) brake power not reached and C101500. Mechanical fault..
I shall have a look and let you all know.
Check the shoes for wear and if they're okay then try adjusting them through the brake disc. After they're adjusted just relearn parking brake through diagnostic
 
Thank you. The pads are okay but am going to strip them down and replace whilst I am there. The EPB works, I can hear it go on when I remove the key, but does not release when I select drive. I have to apply the parking brake ( 5 second push to cycle it) for it to release. Needs a proper looking at next week, if it stops raining.
Does the re learn need to be SDS or will the car just adapt to the new Epb pads as it did with the disc pads ?.
 
Thank you. The pads are okay but am going to strip them down and replace whilst I am there. The EPB works, I can hear it go on when I remove the key, but does not release when I select drive. I have to apply the parking brake ( 5 second push to cycle it) for it to release. Needs a proper looking at next week, if it stops raining.
Does the re learn need to be SDS or will the car just adapt to the new Epb pads as it did with the disc pads ?.
Yes the parking brake shoes will need to be adapted via xentry or any diagnostic that will be able to do it
 

Users who are viewing this thread

Back
Top Bottom