Vacuum headache w163

Cjmb1991

New Member
Joined
Apr 25, 2021
Messages
3
Location
London
Car
Ml270
Afternoon all.

I'm am having a nightmare with my w163 ml270.... only just bought the car and everything was fine. But then it started to choke itself and kept cutting out.

Started checking everything and realised the turbo actuator was constantly fully down. Surely this isn't correct. When i remove the vacuum pipe from the transducer it is constantly pulling a vacuum. Same as the egr valve. Surely they should only be pulling a vacuum when required to love.

First mercedes I've owned so I'm after a little help.

No fault codes in any system. When I remove the pipe from the turbo actuator the car runs like a dream. Obviously no boost pressure but it runs smoothly with no issues.

I've removed the egr and it isn't seized. No boost leaks. I dont know what to do next. I appreciate any advice as I'm having to drive a smart car until this is fixed and I'm 6ft 2 so it's not ideal
 

Dodipops

Active Member
Joined
Apr 6, 2019
Messages
238
Location
Scotland
Car
C63
I thought that was how they worked? When you start the car it should suck the actuator rod down, it then regulates the turbo by controlling that vacuum via the transducer. (the egr and turbo transducers are the same so worth a swap of positions).

You could try with MAF disconnected and also check the exhaust for any blockages. I’d also look at inlet port shut off motor, linkage and flaps.
 
OP
OP
C

Cjmb1991

New Member
Joined
Apr 25, 2021
Messages
3
Location
London
Car
Ml270
Thanks for the reply. Both transducers have been replaced. Has a de cat. I think I'm going to rip the inlet manifold off tomorrow after work. Not sure how involved of a job it is though
 

Dodipops

Active Member
Joined
Apr 6, 2019
Messages
238
Location
Scotland
Car
C63
It’s not to difficult, to help with access you can take the passenger side wheel arch liner out and that helps you get to the underside (you can do it all from the top)
 
OP
OP
C

Cjmb1991

New Member
Joined
Apr 25, 2021
Messages
3
Location
London
Car
Ml270
Sweet. I will attack tomorrow or Wednesday and see what I find. Would that cause it to run rough even with the turbo actuator vacuum disconnected? As it runs like a dream when I pull the vacuum off
 

Dodipops

Active Member
Joined
Apr 6, 2019
Messages
238
Location
Scotland
Car
C63
Not 100% sure, when you remove the pipe from turbo are you then blocking it off or just leaving it sucking?
If the later does it run rough when blocked?
 

Users who are viewing this thread

Top Bottom