Vito 2009 115 2.2 nitemare…

Page may contain affiliate links. Please see terms for details.

MattEVans

New Member
Joined
May 5, 2020
Messages
10
Location
Reading
Car
2009 Vito 115
Good afternoon. I really hope some light can be shed on my issues.

I have a Vito 115 and the fuel economy is diabolical 10-12mpg.

I have fixed the Black Death with new injectors (coded appropriately), seals. Glow plugs and the electrical connectors in the injectors.

The idle is rough, it’s sometimes turns over for an extended period before firing… the idle is so rough, and has so many flat spots …

It’s has a new MAP, Camshaft sensor and intake temp sensor.

With a code reader it shows a MaF flow rate at idle of 12g/sec but when engine is off it shows 1.8g/sec.

Further when the engine is off there is no fuel rail pressure, but when running is about 25,000 kpa..

Finally there is a cat temp sensor bank 1 but this is a diesel. And they read sensor 1 -40 degrees and sensor 2 2203 degrees…

I would really appreciate some help, or direction.

Also the mechanic said when coding the new injectors there were 6 all with codes, but this is a 4 cylinder one

Has anyone got a star machine near Reading please…
 
The injector's need to have their calibrations done on Star.
Although not sure I believe they will set themselves up with continual corrections while running??

Star can also check for smooth running, and show if a cylinder isn't pulling its weight.

Otherwise the MAF may be out while running,
as with the Lambda.
But at such a diabolical consumption I would expect if either were out that much the mil would be up.
 
The injector's need to have their calibrations done on Star.
Although not sure I believe they will set themselves up with continual corrections while running??

Star can also check for smooth running, and show if a cylinder isn't pulling its weight.

Otherwise the MAF may be out while running,
as with the Lambda.
But at such a diabolical consumption I would expect if either were out that much the mil would be up.
When you smash calibration what does that entail? They were coded to the cylinder or does more need to be done

The lambda sensor has been changed and the voltage monitored when running is stuck at 0.05 it doesn’t fluctuate
 
When you smash calibration what does that entail? They were coded to the cylinder or does more need to be done
The code on new injectors is valid, but I read that on reconditioned injectors the code from the top isn't.
There are zero quantity calibrations at tick over,
and zero quantity while running.
1st takes about 15 minutes and the Star / DAS does its thing while your sat.
the 2nd takes about 25 minutes and you've to rev, coast, brake and the system does its stuff.
Both require parameters to be met prior to the calibration, such as engine temp, air intake temp.....

The lambda sensor has been changed and the voltage monitored when running is stuck at 0.05 it doesn’t fluctuate
Mine is the 651 engine, but coasting the Lambda sits at 2, otherwise it fluctuates between 1.1 and upward.
That looks like an issue there.
 

Users who are viewing this thread

Back
Top Bottom