W/S204 EML Light, Limp Mode and Error Code P2015

Discussion in 'Engine' started by imprezarb5, Sep 29, 2013.

  1. imprezarb5

    imprezarb5 Member

    Messages:
    31
    Joined:
    Sep 20, 2013
    Car:
    Mercedes
    Hello all,

    A week into ownership of my S204 C320 CDI i have run into problems with the EML light on, and the car reverting to limp mode.

    Car was attended by breakdown organisation this morning, and Error Code P2015 identified, which appears to point towards Intake Manifold Runner Position Sensor. He removed the engine cover and checked the manifold connections.

    At this point the EML Light went out , and the car was no longer in limp mode. However performance was/is still sluggish and i also noticed that the exhaust tips were now quite black with carbon deposits.

    Doing some research on here, points towards inlet port shut off motor / intake motor failure.

    any comments/observations are of course welcome with any recommendations as to who/where can get this rectified for me reasonably in the Beds/Herts/Bucks region.

    many thanks in advance.
     
  2. WG M-B

    WG M-B Auhorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    1,898
    Joined:
    May 26, 2011
    Location:
    N/W london
    Car:
    C63 Wagon in black
    Yes it does indeed point to the ips motor.
    We would be happy to quote you if needed.
     
  3. OP
    OP
    imprezarb5

    imprezarb5 Member

    Messages:
    31
    Joined:
    Sep 20, 2013
    Car:
    Mercedes
    Due to the overwhelming response, booked in with WG-MB.

    local independant didnt even bother to call back, so prefer to take my business to someone who showed an interest, despite being further away.
     
  4. OP
    OP
    imprezarb5

    imprezarb5 Member

    Messages:
    31
    Joined:
    Sep 20, 2013
    Car:
    Mercedes
    :thumb: Resolved following a visit to WG-MB, with the IPS Motor replaced

    Many thanks to Terry and his team, for the prompt reply and problem resolution.

    Happy to recommend them to forum members.
     
  5. kit17

    kit17 Active Member

    Messages:
    602
    Joined:
    Dec 29, 2009
    Location:
    Norfolk
    Car:
    W205 C63

    Glad you got sorted out mate, hopefully it wasn't a too expensive experience!
     
    1 person likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.