w124 300d '96 - heater control not lit

Discussion in 'Electronics' started by bigyin1, Sep 24, 2008.

  1. bigyin1

    bigyin1 Hardcore MB Enthusiast

    Messages:
    334
    Joined:
    Aug 26, 2008
    Location:
    Daventry
    Car:
    '96 W124 300D
    Specifically the right hand heater control isn't lit, whereas the left is. Is there one bulb behind one, and one behind the other. If so how do you access it/them?

    Also, is the main headlight switch to the right of the steering wheel supposed to be illuminated when the headlights are on?

    Cheers.
     
  2. SilverSaloon

    SilverSaloon MB Club Veteran

    Messages:
    7,759
    Joined:
    Mar 16, 2004
    Car:
    1994 W124 E300D Estate, 1985 R107 280SL
    headlight switch should NOT illuminate - the positions on the sorround should though.

    the heater kob has a bulb in it - probably just blown. I dont know how to remove this, as i've never done it but maybe its just a pull off job - but dont quote me as it may break!!! you may need to remove the wood trim 1st?

    i am sure Bolide or IanBWalker will know for sure

    if no one comes up with an answer i'll check my Haynes manaual tonight
     
  3. bolide

    bolide Hardcore MB Enthusiast

    Messages:
    3,726
    Joined:
    Oct 8, 2005
    Location:
    Brighton
    Car:
    BMW E39 525 Diesel Touring
    The heater & headlight knobs pull off. I use a pair of pliers and a thick cloth to avoid making the knob

    MB dealers have the bulbs

    Nick Froome
    www.w124.co.uk
     
  4. Ade B

    Ade B Hardcore MB Enthusiast

    Messages:
    1,832
    Joined:
    Nov 26, 2006
    Location:
    South London
    Car:
    2006 Accord Tourer iCDTI EX
    IIRC the headlight switch on mine lights up orange when the fog lights are switched on.

    The only light out on mine is the roller on the centre vents - I have yet to muster the enthusiasm to pull the dash apart to replace it..:rolleyes:

    Ade
     
  5. Timster

    Timster Hardcore MB Enthusiast

    Messages:
    556
    Joined:
    Jun 24, 2008
    Location:
    Scottish Borders
    Car:
    Currently Merc' Less.
    Hi.

    The heater control switch should light. I presume you mean the temp selector wheel rather than the blower switch.

    If it's just the blower switch then it simply pulls off, if it's the wheel you have to go a bit further.

    First pull off both the blower switch and the air direction switch - a good firm pull will get them, although it feels like they won'd come at first.

    Then remove the big nut (1 for each switch)

    Then remove the wood trim - 2 small screws just above the stereo, it then lifts off from the bottom first

    Then pull out the heater unit with the switch in it, the bulb should be obvious then. Think mine cost about £1.50 from halfords.

    Oh, the headlight switch itself isn't lit until pulled twice for rear fogs, then it's orange. But the area around it saying the switch positions are, or at least, should be!

    Good Luck!
     
  6. Frank O' Phile

    Frank O' Phile Hardcore MB Enthusiast

    Messages:
    907
    Joined:
    Mar 9, 2008
    Location:
    out there
    Car:
    gone
    Make sure you replace with the correct wattage. Not all miniature capless bulbs are the same.
     
  7. OP
    OP
    bigyin1

    bigyin1 Hardcore MB Enthusiast

    Messages:
    334
    Joined:
    Aug 26, 2008
    Location:
    Daventry
    Car:
    '96 W124 300D
    cheers everyone. Yes the temp selector, right hand one isnt lit. Also the area around the headlights isn't lit - is there a bulb behind there that's releatively easy to get to too?
     
  8. Frank O' Phile

    Frank O' Phile Hardcore MB Enthusiast

    Messages:
    907
    Joined:
    Mar 9, 2008
    Location:
    out there
    Car:
    gone

    The headlight switch, pulls off (eventually) and you will see the foglight indicator bulb (remove this) and again there is a large nut to undo. (Might also be a screw, can't remember) and the bulb is behind the plastic surround. Replace the foglight indicator bulb while you're at it.
     
  9. OP
    OP
    bigyin1

    bigyin1 Hardcore MB Enthusiast

    Messages:
    334
    Joined:
    Aug 26, 2008
    Location:
    Daventry
    Car:
    '96 W124 300D
    from other post:

    Brilliant timing, just picked up some new bulbs on Saturday.

    BUT on your picture number 2 where it says remove the stereo and then the two bolts, i did but i don't have two bolts?

    I was quite impressed with myself to get that far to be thwarted by not having two bolts when there were supposed to be two (plus i was due to start work...).

    Any thoughts anyone? (I'll try the headlight surround during lunchbreak)...
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.