W124 300d glow plug related??

Discussion in 'Engine' started by krimat2005, Jul 9, 2011.

  1. krimat2005

    krimat2005 Hardcore MB Enthusiast

    Messages:
    317
    Joined:
    May 31, 2009
    Location:
    Littlehampton, West Sussex
    Car:
    Mercedes W124 300D/ S203 220cdi
    Hi everyone, my problem is that sometimes glow plug light comes on when it shouldn't. before starting the engine it goes on and off as it should, but after starting sometimes it's on right away, or after some time ( like anything between 5-20min ) or is not coming on at all sometimes. well first thought glow plugs ( changed about 1 year ago) so checked them and they all pretty much at 1,3-1,5 Ohms, so they're ok. then i remembered i was playing with my temp sensor ( one with 2 pins in the head ) and I know that one of those pins goes to temp guage on dash ( it's showing ok about 85-90 after warm up) the other pin goes to glow plug relay and it's responsible for "afterglow" ( I presume if it's not good it might mess up and light is comming on when it not supoused to). so do you guys think I have a bad temp sensor? or is it glow plug relay? how do i check for both??
     
  2. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    Check the glow-plugs again as they may be faulty under load.
     
  3. Number_Cruncher

    Number_Cruncher Hardcore MB Enthusiast

    Messages:
    987
    Joined:
    Jan 14, 2008
    Location:
    Midlands
    Car:
    1995 E300D
    Check the condition of the engine wiring loom - particularly near the temperature sensor towards the rear of the head (under the manifold).
     
  4. OP
    OP
    krimat2005

    krimat2005 Hardcore MB Enthusiast

    Messages:
    317
    Joined:
    May 31, 2009
    Location:
    Littlehampton, West Sussex
    Car:
    Mercedes W124 300D/ S203 220cdi
    how do i check plugs under load?
     
  5. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    Take them out and connect to the battery.
     
  6. compress ignite

    compress ignite Hardcore MB Enthusiast

    Messages:
    208
    Joined:
    Jun 4, 2006
    Location:
    32 degrees North by 81 degrees West
    Car:
    '90 300D 2.5
    Answers are Above

    Even if the "Afterglow" function is in operation,the Dash "PreGlow" bulb WILL NOT Illuminate.

    There's a neat Modification to allow you to Know If the "AfterGlow" is in operation:
    W124/OM603 Afterglow DIY - PeachParts Mercedes ShopForum

    Read on Down in the Post...Jeremy uses an "Empty" hole in the I.C. to plug in
    a Bulb that Lights up whenever the Glow Plugs are in Operation.
     

    Attached Files:

    Last edited: Jul 10, 2011

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.