w124 coupe no radio signal

Discussion in 'Electronics' started by horgantrevor, Oct 12, 2011.

  1. horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    hi i have a friend that has no radio signal the usual items have been checked

    the model radio is mexico typ 2330 becker cd radio fitted from factory

    is their a amp in this car for the radio in the rear pillar

    any help would be great

    we have noise from speakers just no radio signal
     
  2. carat 3.6

    carat 3.6 MB Enthusiast

    Messages:
    3,923
    Joined:
    May 11, 2011
    Location:
    Buckinghamshire, yuppie central 1985.
    Car:
    96 e300d, 88 w124 superturbodiesel, 90 bmw E30 v8, + "others"
    Have you checked the conections at the antenne and the back of the radio? Dose the radio antenne extend fully?
     
  3. OP
    OP
    horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    it wont extend fully but all connectors are good checked all but i never checked if their was a radio amp in the rear pillar like the w202 for the RF and IR signal
     
  4. grober

    grober MB Master

    Messages:
    27,940
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    Not usually a radio amp in the normal setup- just a straight coaxial cable. Possibly a bad /corroded antenna ground strap to earth connection where it attaches to the car body or broken antenna strap
     
  5. carat 3.6

    carat 3.6 MB Enthusiast

    Messages:
    3,923
    Joined:
    May 11, 2011
    Location:
    Buckinghamshire, yuppie central 1985.
    Car:
    96 e300d, 88 w124 superturbodiesel, 90 bmw E30 v8, + "others"
    On my estate there is no signal atall untill the antenne is fully up.

    How far dose it go? A w124 has quite a tall mast.
     
  6. OP
    OP
    horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    it only goes up about a foot

    its a friends car he only called for a small while the other nite so i didnt have much time too look at it as he had to go

    ill keep you posted

    thx again for the help
     
  7. GP801

    GP801 MB Enthusiast

    Messages:
    2,906
    Joined:
    Jun 18, 2010
    Location:
    Sussex and Tuscany
    Car:
    2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
    No amplifier but our estate had a second junction connection in the drivers footwell. When we got the car the radio signal was rubbish. On investigating there were 3 different aerial leads presumably from various new aerials fitted in the life of the car. Turned out the current aerial was not connected to the lead going to the radio.
     
  8. Ian B Walker

    Ian B Walker MB Enthusiast

    Messages:
    7,672
    Joined:
    Jun 7, 2003
    Location:
    Freckleton
    Car:
    300-24, saloon and coupe, E300 24 valve diesel estate
    Have the fuses been checked?
     
  9. OP
    OP
    horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    yes ill see the car again soon ill have more info then


    thank you for the ideas to check ill post back
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.