W124. E320 Wiring loom

Quiamare

New Member
Joined
Apr 17, 2014
Messages
2
Car
W124 E320 Cabrio. 1994.
Hi All First post here and I looked at the others and YouTube but can’t find my issue. In one thread I found that if the wire to the temp sensor on the thermostat body was blue and not green I have a new loom. It is so I’m assuming the loom was swapped out before I bought it. Car is an 2994 A124 E320 originally a German registered car. Looking at the loom in detail and comparing to the posts I’ve seen I have at the front of the engine two connectors that are loose and no vacuum unit to connect to. No vacuum tube either that others seem to have. Also their is a complex conector that is also loose on the left side of the engine after the inlet manifold and I can’t see where that goes. Does anyone have any idea why this is so. The car seems to run just great except for auto gearbox flaring but that’s only recent.

Photos attached

Thanks for any clues you can give me
 

Attachments

  • 95FC85C9-FD99-46CC-9FE7-48FB7E75254A.jpeg
    95FC85C9-FD99-46CC-9FE7-48FB7E75254A.jpeg
    1.7 MB · Views: 6
OP
OP
Q

Quiamare

New Member
Joined
Apr 17, 2014
Messages
2
Car
W124 E320 Cabrio. 1994.
Hi All First post here and I looked at the others and YouTube but can’t find my issue. In one thread I found that if the wire to the temp sensor on the thermostat body was blue and not green I have a new loom. It is so I’m assuming the loom was swapped out before I bought it. Car is an 2994 A124 E320 originally a German registered car. Looking at the loom in detail and comparing to the posts I’ve seen I have at the front of the engine two connectors that are loose and no vacuum unit to connect to. No vacuum tube either that others seem to have. Also their is a complex conector that is also loose on the left side of the engine after the inlet manifold and I can’t see where that goes. Does anyone have any idea why this is so. The car seems to run just great except for auto gearbox flaring but that’s only recent.

Photos attached

Thanks for any clues you can give me
 

Attachments

  • 01690F75-25E4-4806-8497-146FD63CE256.jpeg
    01690F75-25E4-4806-8497-146FD63CE256.jpeg
    1.1 MB · Views: 5

grober

MB Master
Joined
Jun 22, 2003
Messages
30,683
Location
Perth, Scotland
Car
W204 ESTATE
They will be universal replacement engine looms incorporating all likely components to be fitted to the W124 of that vintage. If the car is running fine nothing to worry about.
 

Users who are viewing this thread

Top Bottom