W125 500E coolant temp sensor

Discussion in 'Engine' started by DaleB, Feb 4, 2017.

  1. DaleB

    DaleB New Member

    Messages:
    27
    Joined:
    Apr 18, 2009
    Location:
    Darlington, North East
    Car:
    1990 560sec
    Gents,

    My temp gauge is showing a consistently low temperature (40-50C). So I plan on replacing both the thermostat and temp sensor.

    Could someone please confirm where the sensor is located. I've done a few searches on-line but never seem to find one for my engine.

    Cheers Dale

    Oops obviously meant to type W124 :)
     
  2. grober

    grober MB Club Veteran

    Messages:
    27,476
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    The engine is a M119 if you search M119 + temperature sensor you should get some pics. IIRC they are all located on a block at the front of the central multibranch inlet manifold [ under a plastic cover] Remember there are at least 2 one for the injection system and one for temperature gauge. Check which is which with ignition on/engine off but warmed up. Removing the gauge sensor connection should be obvious when you remove it momentarily.
     
  3. OP
    OP
    DaleB

    DaleB New Member

    Messages:
    27
    Joined:
    Apr 18, 2009
    Location:
    Darlington, North East
    Car:
    1990 560sec
    Thanks Graeme,

    Now that I've looked under the cover it's easy to find .... as you can tell I'm new to 500E's :)
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.