W166 2014 bulb failure warning with led's on caravan

Discussion in 'Electronics' started by Corkyball, Jun 8, 2017.

  1. Corkyball

    Corkyball New Member

    Messages:
    2
    Joined:
    Jun 8, 2017
    Car:
    Ml350 bluetec 4matic
    Hi guys can anybody offer advice on how to stop bulb failure message on command when caravan connected, van has led lights all lights working ok
     
  2. Trickythemerc

    Trickythemerc Hardcore MB Enthusiast

    Messages:
    908
    Joined:
    Feb 1, 2015
    Location:
    South Manchester
    Car:
    CLK 220 CDI Sport 2009
    Bulb failure systems don't like LEDs due to the lack of resistance, you may need a special wiring rig for the caravan lights to fool the bulb failure system into thinking the van has normal wire wound bulbs.
     
  3. 350_Coupe

    350_Coupe Hardcore MB Enthusiast

    Messages:
    782
    Joined:
    Oct 31, 2010
    Location:
    Oxfordshire
    Car:
    2005 C350 Coupe SE
    or do as we have been doing on the car itself, and swap bulbs for CANBUS compliant ones

    is it all of the bulbs that are triggering it, or just some ?
     
  4. Martyn_n

    Martyn_n Hardcore MB Enthusiast

    Messages:
    606
    Joined:
    Nov 27, 2010
    Location:
    Leicester
    Car:
    W124 E320, ML270
    Is it a Swift group caravan? If so you can get a kit from Sargent that fixes this known issue.
     
  5. OP
    OP
    Corkyball

    Corkyball New Member

    Messages:
    2
    Joined:
    Jun 8, 2017
    Car:
    Ml350 bluetec 4matic
    Hi tricky, i am aware about leds offering no resistance, on my earlier ml270 the indicators wouldnt flash at correct speed untill i fitted a special box to my caravan, however you would think it would work on my later 350 but it wont
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.