W176 A200 EML Limp Mode - Diagnostic Results

MDC1992

New Member
Joined
Apr 9, 2021
Messages
2
Location
Bracknell
Car
A200 W176
Hi,

Really need someone’s help!
I’ve had multiple mechanics look at the car and no one can tell me what’s wrong with it....
The car went into limp mode and the EML come on over the winter following a change of Control Units on front passenger running/indicator light (due to the amount of moisture)

I have the following faults codes coming up from my own ODB scanner:

P0473(12)
Raw code: 047312
ECU: Engine control unit
Status: Confirmed, Test failed since last DTC clear, Warning indicator requested
OBDII: Exhaust gas pressure sensor - high input
Mercedes-Benz: Exhaust Pressure Sensor High

============2==============
P0108(12)
Raw code: 010812
ECU: Engine control unit
Status: Confirmed, Test failed since last DTC clear, Warning indicator requested
OBDII: Manifold absolute pressure (MAP) sensor/barometric pressure (BARO) sensor - high input

============3==============
P0473
Raw code: 0473
ECU: Engine control unit
Status: Pending
OBDII: Exhaust gas pressure sensor - high input
Mercedes-Benz: Exhaust Pressure Sensor High

============4==============
P0236
Raw code: 0236
ECU: Engine control unit
Status: Pending
OBDII: Turbocharger (TC) boost pressure sensor A/supercharger (SC) boost pressure sensor A - range/performance problem

============5==============
P2227
Raw code: 2227
ECU: Engine control unit
Status: Pending
OBDII: Barometric pressure (BARO) sensor - range/performance problem

============6==============
P0238
Raw code: 0238
ECU: Engine control unit
Status: Pending
OBDII: Turbocharger (TC) boost pressure sensor A/supercharger (SC) boost pressure sensor A - high input

============7==============
P0108
Raw code: 0108
ECU: Engine control unit
Status: Pending
OBDII: Manifold absolute pressure (MAP) sensor/barometric pressure (BARO) sensor - high input

============8==============
P0473
Raw code: 0473
ECU: Engine control unit
Status: Confirmed
OBDII: Exhaust gas pressure sensor - high input
Mercedes-Benz: Exhaust Pressure Sensor High

============9==============
P0108
Raw code: 0108
ECU: Engine control unit
Status: Confirmed
OBDII: Manifold absolute pressure (MAP) sensor/barometric pressure (BARO) sensor - high input

I have already have the following changed or tested:

MAP sensor replaced
Boost pressure sensor replaced
Cloned ECU tested
A couple wires from engine to ECU fixed

When I got the Boost pressure sensor replaced, it worked for the evening, but the car now goes back into LIMP MODE and the EML on.
I have tried to clear the codes, but even with the EML off, it is still in limp mode.

Any one else experienced this or can help please?

Cheers
 

Tuercas viejas

Active Member
Joined
Mar 26, 2017
Messages
880
Location
Denver
Car
landrover/rolls royce/MB AMG S600/Prius
It help if you post LIVE Data figures with the scan tool you have in KOEO & KEOR .
Then it maybe possible by remote to pinpoint the issue.
Tuercas Viejas
 

Users who are viewing this thread

Top Bottom