W202 C240 Estate wierd going ons

320 CLK

Member
Joined
Feb 7, 2015
Messages
39
Location
Bangor Co . Down
Car
Mercedes C240 Estate
Hi. My 1998 C240 estate seems to be acting wierd. All works fine then it won't open from passenger side with remote key,opens from drivers then the passenger window and mirror dose not work. Disconnect the battery reconnect all is fine. Then will do the same sometimes from the drivers side. Sometimes you have to open it withe the blade of the key. Car will start and drive fine. But then it will have no indicators horn windows mirrors. Do a battery reset and all is fine for awhile. Very annoying.
Could anyone shed any light or experienced this. Thanks.
 
Last edited:
OP
OP
320 CLK

320 CLK

Member
Joined
Feb 7, 2015
Messages
39
Location
Bangor Co . Down
Car
Mercedes C240 Estate
Hi. Anyone any ideas. It would be greatly appreciated.
 

andy27168

MB Enthusiast
SUPPORTER
Joined
Nov 27, 2004
Messages
4,518
Location
Southampton
Car
1997 C230K, 1999 C43/55 AMG
Hi,
This sounds like it could possibly be a faulty K40 module, it is part of the front fuse box.
Careful identification of it will be required as there are more than one type, dependant on cars specification and age.
If you take a look at the ebay link below you will see what it looks like and is located under the fuse box under the bonnet driver's side.
You will also see in the pic of it a part number on its flat surface just below and to the rear of the large orange fuse, which you will need to look for on yours to enable you to identify the correct one for your car.
Once you have your number type that number into E-Bay and I am sure you will find one second hand.
Mercedes Overload Relay OVP 0005400072 K40
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom