W202 C36 AMG Throttle issues…

Johnsnz

New Member
Joined
Mar 19, 2022
Messages
4
Location
Auckland NZ
Car
C36 AMG
Hi,

My first post and I’m also based on Auckland NZ so forgive me if I stuff this up somehow.

I have a 95 W202 C36 that I’m currently working on as a project car I’ve had it a couple of months and have been working through issues such are refreshing the suspension and steering and now I’m moving onto engine issues.. one of which is the throttle.

I have what seems to be a sticky throttle.
The throttle Closes ok and I think I get the full range of motion. I have a small bit of initial throttle and then a bucket load which make in town driving a bit interesting.. a little bit of pedal pressure gives me a bit of throttle then nothing then lots of throttle.
The pedal is free and lubricated and I gave the throttle linkages a blast with crc (wd40).

I’m happy to go digging but greatful for some advice.

Thanks

John S
 
OP
OP
J

Johnsnz

New Member
Joined
Mar 19, 2022
Messages
4
Location
Auckland NZ
Car
C36 AMG
Possibly… How would I check? The throttle body is Non ASR and you can hear the motor / solenoid chirping happily when the key is energised. Car idles fine at around 6-700 rpm.

( what do the electronics on the non ASR TB actually do??)

I popped the intake tube off today and there was a bit of crud on the butterfly so I cleaned that off with some throttle body cleaner and a detailing brush.
Lubed all of the throttle link pivots and worked em back n forth they seem free enough.
I used the cable adjuster to tweak up all of the
(minimal) slack in the cable.
 

Users who are viewing this thread

Top Bottom