w203 (2004) c220cdi intermittent start issue getting worse

Discussion in 'Engine' started by tordofm, Sep 4, 2011.

  1. tordofm

    tordofm New Member

    Messages:
    9
    Joined:
    Sep 8, 2006
    Location:
    South East Kent
    Car:
    c220cdi w203 est, command, elec climate, parking sensors, leather, BT phone, heated seats, auto L&W
    Hi,

    For the last 2 months I have had 3 or 4 occasions whereby the engine does not start but it turns over for a few seconds until I stop it. On the next turn it works fine (within 1/2 a second). Tonight I tried 4 times but it never fired up (engine was cold), I left it for five minutes and put my basic OBD tool on it and no codes. I tried it again and it started without hesitation as it normally does.

    Does anybody have any thoughts before I take it for a star checkup?

    Thanks

    Marc
     
  2. Rory

    Rory MB Enthusiast

    Messages:
    7,332
    Joined:
    Mar 12, 2005
    Location:
    Cheshire, UK
    Car:
    C270CDi Estate (late 2004 facelift model)
    Ignition switch (EIS)?

    Air leaks or low fuel pressure can produce similar symptoms, but the car usually starts after a bit of cranking, rather than not starting and then starting instantly on the next try.
     
  3. brucemillar

    brucemillar MB Enthusiast

    Messages:
    8,663
    Joined:
    Nov 18, 2010
    Location:
    Next Door to Alice - 25 'kin years now
    Car:
    C55 AMG Wagon - W124 300te 4matic Wagon - BMW 4.8is X5 E53 - SWB Pajero 3.5 V6 24v
    Crank Position Sensor? get it on a STAR that will show if that is the issue.
     
  4. OP
    OP
    tordofm

    tordofm New Member

    Messages:
    9
    Joined:
    Sep 8, 2006
    Location:
    South East Kent
    Car:
    c220cdi w203 est, command, elec climate, parking sensors, leather, BT phone, heated seats, auto L&W
    Thanks for all the advice, as I am more electrical than mechanical I think I will get it put on a star diagnostics machine asap and will report on what codes are hopefully showing up.

    Marc
     
  5. OP
    OP
    tordofm

    tordofm New Member

    Messages:
    9
    Joined:
    Sep 8, 2006
    Location:
    South East Kent
    Car:
    c220cdi w203 est, command, elec climate, parking sensors, leather, BT phone, heated seats, auto L&W
    I just got my local MB dealer to run star on the car. It cam back with:

    2043-001 check component B6/1 (camshaft hall sensor) no signal
    2043-002 check component B6/1 (camshaft hall sensor) signal faulty

    The code had been logged 60 times (much more than I had expected) and I was informed it may have tripped when driving but it would not cause the engine to stop but would have thrown a fault code.

    So not the crank but the camshaft sensor which I was told is fairly easy to change.

    Thanks for your help

    Marc
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.