W203 320CDI Limp Mode

Jim_Bo

New Member
Joined
Jun 11, 2009
Messages
16
Location
Cambs/Herts
Car
W203 55 plate C320CDI Sport
Guys,

I've been having an intermittent problem with my car going into limp mode ever since i purchased it. I thought i'd solved the problem a few months back after replacing a split boost pipe.

However half way into the journey to work it slipped back into limp mode with the normal stop turn off and restart failing to make any difference. I had exactly the same problem on the way home.

A friend has his own garage so I called in to get any codes read and got the following:
2510 Check component Y77/1 (boost pressure regulator) positioner signals fault
2513 Check component M55 (inlet port shut off motor) positioner signals fault
3090 Test connection terminal circuit 87 the signal voltage is too low.

Any advice on what would have cause this, possible solutions, rough cost etc would all be greatly appreciated.

Thanks in advance

James.
 

davidjpowell

MB Enthusiast
Joined
Nov 8, 2007
Messages
4,912
Location
Doncaster
Car
E350 w212 and Ford Ranger
Common fault is the port inlet shutoff motor which is below the turbo, which can drop oil onto it, killing in the process

I paid £450 at an indie.

Dealer I think can be up to £700

Could be something else of course.
 
OP
OP
J

Jim_Bo

New Member
Joined
Jun 11, 2009
Messages
16
Location
Cambs/Herts
Car
W203 55 plate C320CDI Sport
Thats not really what I wanted to hear, but thanks. Did you have any of the other codes too?
 

crockers

MB Enthusiast
Joined
Mar 30, 2007
Messages
7,097
Location
North Wilts
Car
XC60 MY2014 SeLux Nav plus lot and lots of toys...
Main dealer charge is just under £600. I've had mine go 3 times. Now have letter from Mercedes stating max I will ever have to pay for this is 10% of cost. Very common problem but very very rare to go more than once. A rectified oil seal should solve problem.
 

andysej

Member
Joined
Mar 3, 2007
Messages
30
Location
Hillam
Car
S211 e320cdi 2008. Suzuki gt250x7. Suzuki GSX1400FE
Just had inlet port shut off motor done on mine, car not yet 3 year old. Symptoms were exactly as you describe James. Codes were read and repair done by MB.
 
Last edited:

rashg60

New Member
Joined
Sep 3, 2012
Messages
1
Car
Mercedes CLS
My CLS is experiencing the exact same symptoms with the following two codes from the diagnostics read out today:-

2510 Check component Y77/1 (boost pressure regulator) positioner signals fault
2513 Check component M55 (inlet port shut off motor) positioner signals fault

Is this really a big problem and expensive as you guys state???? That has really scared me as I didn't wanna hear that either.

Jim_Bo let me know how you get on.
 

JanM

New Member
Joined
Jul 11, 2013
Messages
1
Car
E280 CDi
I've juat had the same problem / diagnosis

I took my car (E280 CDi - May 2007 NEW purchase) to a garage (way away from Mercedes Dealer as i found my MB Dealership extremely arrogant, even though i've always had my car serviced with them, from New)

The diagnosis was:
Boost Pressure Regulator - Signal Fault

The garage told me that i had a choice of:

1. Replacing the entire Turbo with a NEW 'OEM' (Garrett) Turbo for £1060 + VAT (This apparently comes with a 12 Month warranty)
OR
2. Get a Mercedes Benz 'RE-Conditioned' Turbo for £1200 + VAT (This apparrently comes with a 3 months warranty)
OR
3. Get a Brand New Mercedes Turbo unit for approx: £2200 + VAT

and the labour for fitting it would be around £300 + VAT

I haven't a clue what i should do. :crazy:

Can anyone suggest what i should do?

Mant thanks

Jan
 

donshl

MB Enthusiast
Joined
Oct 11, 2010
Messages
1,123
Location
London
Car
CLS55 AMG
I don't know about turbo's, but from what I know mercedes Re-Man parts still carries the same warranty period as new parts. This is what they proudly say on the dealership displays!
 

Merc'e

New Member
Joined
Mar 10, 2016
Messages
3
Car
Mercedes C320 CDI SPORT
Bit later now than the last comment, but my car C320 CDI went into limp mode, star read inlet port shutoff motor fault, on finally getting my car in a garage the inlet port shutoff motor was fine, my inlet manifolds were knackered, very expensive. Oh the joy of owning a merc
 

Users who are viewing this thread

Top Bottom