w203 battery

dav007

Active Member
Joined
May 27, 2009
Messages
333
Location
london
Car
w203 c class
hi there seem to be haveing a problem with starting in the morning bit strange as i when i plug the house car chager on th charges for a min then states full chagered so when it happened again the checked the volts at the battery and it showed 12.4 volts so the battery charger is only charging it an extra 0.3 in to the battery

is this right that .3 of a volt would not turn over the car
 

OneForTheRoad

MB Enthusiast
Joined
Apr 20, 2015
Messages
2,703
Location
uk.
Car
2017 e350 c207 .. +65 ford kuga 2.0 cdi zetec awd..
Leave it on charge for a few hours . 8 amps if possible . Sounds like some of the cells are dodgy and not letting voltage through . A forced charge sometimes wakes them up . If you manage to get the battery to acept a charge . Leave it on 4 amps for 24 hours
 
OP
OP
D

dav007

Active Member
Joined
May 27, 2009
Messages
333
Location
london
Car
w203 c class
hi my battery charger stops cos the battery is full charged
 

Notwen

Active Member
SUPPORTER
Joined
Nov 17, 2013
Messages
202
Location
Pendle, Lancashire
Car
C36 AMG, C43/55 AMG & SLK350
Could be sulphated. Has it been allowed to stay discharged for extended periods ?
12.4v is about 80% charged so should start, resting voltage ideally would be above 12.5v
If possible, disconnect the battery from the car, allow to rest for a while, check the voltage. If it continues to fall it could be toward the end of it's working life.
How old is it and does it have accessible cell caps?
 
OP
OP
D

dav007

Active Member
Joined
May 27, 2009
Messages
333
Location
london
Car
w203 c class
only over night i use it almost dayley only had the car over a 1 year and a bit the guy i bought the car of said he changed it a year ago so we are looking at about 2 years a abit

its a banner battery in the car it does have caps all levels are full
 

OneForTheRoad

MB Enthusiast
Joined
Apr 20, 2015
Messages
2,703
Location
uk.
Car
2017 e350 c207 .. +65 ford kuga 2.0 cdi zetec awd..
the battery charger stops because it thinks the battery is fully charged. that's due to the battery being kaputtttttt !!!!!!..... try a not so clever charger and force a charge into it over a few hours , it might just kick it into life .
 

Notwen

Active Member
SUPPORTER
Joined
Nov 17, 2013
Messages
202
Location
Pendle, Lancashire
Car
C36 AMG, C43/55 AMG & SLK350
I agree, it needs charge forcing in, if it is likely to recover.
Ideally get a proper battery test done, with a Hydrometer and High rate discharge tester. You can simulate a HRD test by having the engine cranked for 10 seconds (ish)while you have a multi meter connected to the battery. Ideally the voltage will stay above 9v while cranking and then recover back up to around 12.5v when left to rest.
 

nigel cross

MB Enthusiast
Joined
Jan 8, 2005
Messages
2,414
Location
Surrey
Car
W164 ML350 Audi S4
A fully charged battery should read 13.2 volts, the problem could either be a duff cell,or your charger is up the swanney. But as it is going flat whilst being charged on the car, the battery is the likely fault. Battery's should last approx 6 years, so if this one was canged recently by the previous owner, it is either a cheapy or perhaps he was not telling you the whole truth.
 
OP
OP
D

dav007

Active Member
Joined
May 27, 2009
Messages
333
Location
london
Car
w203 c class
thanks all will try and get it tested
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom