W203 C240 Ignition Problem

Discussion in 'Engine' started by GeoffreyAlby123, Sep 22, 2016.

  1. GeoffreyAlby123

    GeoffreyAlby123 New Member

    Messages:
    1
    Joined:
    Sep 1, 2016
    Car:
    C200K
    My W203 C240 Estate has developed a random ignition problem over the last coupe of weeks.

    Sometimes the engine does not start, ignition lights will come on in Position 1 & 2 but nothing happens when I turn to start the engine. Engine does not crank.

    It will not start for 6 or 7 times then randomly start. Have looked at threads on here and tried having foot on footbrake or headlights switched on, this seems to help but not all the time.

    Have also now noticed that if dash is in Trip Computer mode when I turn to position 2 if the Miles/Duration/Speed/MPG digits stay displayed the car will start. But if I turn to Position 2 and the digits arent displayed but just dashs in those fields the engine wont start.
     
  2. grober

    grober MB Club Veteran

    Messages:
    26,094
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
  3. c32pilot

    c32pilot Member

    Messages:
    39
    Joined:
    Sep 7, 2016
    Car:
    C32 AMG
    Does the gear position display show the 'P' on the dash when not working?
    Mine has a similar thing. If I turn the ignition on & the 'P' symbol ISN'T there... it won't turn over. If I turn the ignition on & the 'P' symbol IS there, she'll turn over & fire.
    When it ISN'T there I leave the ignition on for 5 -10 mins & they appear & off we go.
     
  4. grober

    grober MB Club Veteran

    Messages:
    26,094
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    You may have a faulty automatic gear selector position switch. If the car doesn't "know" its in PARK or NEUTRAL it won't start.
     
  5. c32pilot

    c32pilot Member

    Messages:
    39
    Joined:
    Sep 7, 2016
    Car:
    C32 AMG
    Do you know if it's a replaceable part or will I have to get a new complete gear selector module?
     
  6. grober

    grober MB Club Veteran

    Messages:
    26,094
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    Far as I know its one assembly. Here's a walk thro there were changes evidently over the years. A new replacement would be pricey but because of the above you would be best to a} get it checked by star b} be carefull when going the second hand route.
    W203: Automatic transmission does not shift (code P1856) - MBWorld.org Forums
     
  7. c32pilot

    c32pilot Member

    Messages:
    39
    Joined:
    Sep 7, 2016
    Car:
    C32 AMG
    Cheers :thumb:

    Mine seems to work if I leave the ignition on for 5 mins anyway so not a big hindrance at the mo.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.