W203 C320 autobox lurching into 1st

bert301

New Member
Joined
Feb 14, 2016
Messages
9
Car
Mercedes-Benz C320 Avant-garde W203
My engine management light has just come on. It has also gone into some sort of limp mode. Speed is not restricted but high revs (giving it the beans) is.
When I slow to a stop it seems to select what I guess is first gear either too early or before the car has stopped giving that slight lurch and clunk. Car drives smoothly other than that. No problems going up though throughgears etc. The two connected?

Sent from my SGP312 using Tapatalk
 
OP
OP
bert301

bert301

New Member
Joined
Feb 14, 2016
Messages
9
Car
Mercedes-Benz C320 Avant-garde W203
Well, news is not good. Problem is no kick down.
Went to a indy merc garage today, very helpful. Diagnostic test done, show at least 3-4 faults. Sensors, turbo, valve sticking, you name it.
My wallet is bracing itself

Sent from my SGP312 using Tapatalk
 

Aero

Active Member
Joined
Jan 10, 2015
Messages
74
Car
ClS 320CDI
Having read many posts on this kind of behaviour gives me the feeling that once turbos start to misbehave but not totally fail the results can manifest themselves as "gearbox like" problems. Getting the electronic actuator "remanufactured" seems to work for some but not all. Most indies recommend a turbo replacement along with one or two of the breather/oil pipes and seals for good measure. Hope it doesn't turn out too heavy!
 
OP
OP
bert301

bert301

New Member
Joined
Feb 14, 2016
Messages
9
Car
Mercedes-Benz C320 Avant-garde W203
We shall see!
Its booked in on the 19th for a couple of days

Sent from my SGP312 using Tapatalk
 
OP
OP
bert301

bert301

New Member
Joined
Feb 14, 2016
Messages
9
Car
Mercedes-Benz C320 Avant-garde W203
Back from the garage today. Back to its best.
O2 sensor
Inlet port shut off motor
Gearbox oil change.
Plus a few other bits and pieces.
Faily big bill but glad to have it back.

Sent from my SGP312 using Tapatalk
 

Users who are viewing this thread

Top Bottom