W203 Interior Lights not coming on when doors opened

Discussion in 'Interior' started by sparkyc270, Dec 10, 2009.

  1. sparkyc270

    sparkyc270 Member

    Messages:
    47
    Joined:
    Apr 30, 2009
    Location:
    Dromara, NI
    Car:
    S203 in blue
    Hi everyone,

    My 2001 C270cdi Estate developed a fault last night, that I'm hoping someone on here has came across before and can point me in the right direction to solve the problem.

    When I unlock the car with the keyfob (or key) the interior lights do not come on, also when I open the doors the interior lights do not come on as well as the puddle lights (in the bottom of the front doors) when I open the tailgate the rear interior lights do not come on also.

    However, with the key in the ignition and using the overhead panel, all the interior lights work just fine i.e passenger and drivers map lights, main front interior light and rear luggage space lights all illuminate as normal.
    I have made sure that the overhead switch is in the Car Doors Position.

    The front headlights and fog lights, and rear taillights all come on when the car is unlocked and stay on for a short period when the car is locked, then go off. It's just the interior and puddle lights that don't light up.

    Anyone had this problems before?

    Many thanks,

    ..Steve
     
  2. Olivier

    Olivier Hardcore MB Enthusiast

    Messages:
    1,658
    Joined:
    Oct 30, 2008
    Location:
    Edinburgh
    Car:
    E300 TD
    Would that be the driver door switch that is stuck?
    What hasppen when you open the passenger door?
    Olivier
     
  3. OP
    OP
    sparkyc270

    sparkyc270 Member

    Messages:
    47
    Joined:
    Apr 30, 2009
    Location:
    Dromara, NI
    Car:
    S203 in blue

    Hi olivier, it doesn't seem to mater which door I open, I've tried all 4 doors and the tailgate.

    ..Steve
     
  4. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec
    Sounds to me like a possible issue with the central locking / relay that control the interior lights when unlocking via the key fob or opening a door.

    I don't have the knowledge to know where to look for them though.

    When the ignition is ON have you tried opening/closing all doors to check all door switches are working with the interior lights?
    Perhaps a faulty switch is inhibiting correct operation when unlocking?

    Be interesting to see what the experts come up with here.
     
  5. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,184
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2016
    Are you sure the overhead switch is in the centre position for auto operation? Left is On, right is Off (at least on my car)
     
  6. OP
    OP
    sparkyc270

    sparkyc270 Member

    Messages:
    47
    Joined:
    Apr 30, 2009
    Location:
    Dromara, NI
    Car:
    S203 in blue
    Good thinking, tried this but still no lights.:wallbash:

    Mine is different, left is on, centre is off or auto, (blank on the switch) and right is Doors.

    Thanks though, maybe i'll buy a torch :D

    ..Steve
     
  7. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec

    Like your style !:D

    Would this help until you have it sorted?

    [​IMG]
     
  8. JerryC200Cdi

    JerryC200Cdi Member

    Messages:
    53
    Joined:
    Nov 4, 2009
    Don't the interior lights have a setting in the software menu? Could that have reset somehow? Maybe worth checking in the instrument menu.
    Could be a contact issue on the auto position in the center light console.
     
  9. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,631
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, E55 AMG, S500, etc
    The overhead control unit may have gone kaput? Have you tried new bulbs?
     
  10. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,184
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2016
    what's the difference between Auto and Doors?
     
  11. OP
    OP
    sparkyc270

    sparkyc270 Member

    Messages:
    47
    Joined:
    Apr 30, 2009
    Location:
    Dromara, NI
    Car:
    S203 in blue
    Thanks, I'll check that one. but I'm assuming that this is the same time setting as the front headlights...might be wrong here

    all bulbs working fine, I can turn them on from the overhead console and they all work, it's just on entry/exit that they have stopped working.

    I don't have an auto. the switch is just left=on, centre = ? (no markings on switch) and right = doors (looks like a car with all 4 doors open)

    on a side note: tried the gas lamp internal light:bannana:, works well but takes a little time to get going and fills the car with smoke........next thing is to install a chimney for the gas lamp....:D
     
    Last edited: Dec 11, 2009
  12. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec
    MY ST TDCi is like that!
     
  13. hasie

    hasie New Member

    Messages:
    5
    Joined:
    Jul 31, 2014
    Car:
    C320 CDi
    Hi Guys

    New to the forum.

    Hope all is well.

    I recently bought a 2006 c320 CDi. And I have the same issue. Was wondering if the OP found a solution for this?

    Sometimes the interior lights worked when the doors opened at night. Sometimes not.

    Lately they dont work at all.

    The switches are in the correct position, and the bulbs are not blown as one can put them on manually from the overhead control unit.

    When this happens the rear interior light also do not work.


    Can this be the PSE module?

    Where does this sit in a W203? Would like to open it up and check for water damage.

    Many Thanks, any help appreciated
     
  14. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,184
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2016
    The 203 doesn't have a PSE module.
     
  15. hasie

    hasie New Member

    Messages:
    5
    Joined:
    Jul 31, 2014
    Car:
    C320 CDi
    Thanks for the info!

    Any idea where I can start looking?

    A few things stopped working intermittently, and are all now dead(rear interior light, door lights, also bluetooth hfp module does not work from steering). So i guessed its all related from one unit.

    Thx any ideas much appreciated
     
  16. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    Make sure all the fuses are good and all their contacts are clean. (Rear fusebox I think).

    To try and clarify the operation of these lights. They will not come on in daylight when set to Auto.

    The main switch, bottom centre in picture, has three positions - Left is On (Either day or night) Centre is Auto (Only works in low light) Right is Off.

    The other switches are obvious I think, but Left & Right switches are map reading lights and the top centre one is the rear roof light.

    HTH
    [​IMG]
     
  17. hasie

    hasie New Member

    Messages:
    5
    Joined:
    Jul 31, 2014
    Car:
    C320 CDi
    Thanks for the help

    All the fuses and switch positions are correct.

    I found this indication on Welcome to the C-Class!

    and see the door switches are wired to the rear sam.

    Ill start faultfinding it from there this weekend

    Cheers
     
  18. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    Just one thought, do your headlights/sidelights work ok when the switch is set to auto? Just wondering if your light sensor is U/S.

    I have a wiring diagram for the interior lights in the Haynes Manual, if it would be helpful let me know.
     
  19. whitenemesis

    whitenemesis MB Club Veteran

    Messages:
    15,184
    Joined:
    May 7, 2007
    Car:
    Lexus RC300h F-Sport 2016
    Light sensor normally fails to night mode
     
  20. hasie

    hasie New Member

    Messages:
    5
    Joined:
    Jul 31, 2014
    Car:
    C320 CDi

    Yes the headlights work when set to auto. Also when I unlock the car the headlights come on.

    The boot light also works when opened.

    Thank you, that would be very helpful for me! Would you be able to send me a photo or the like of it?

    Many Thanks!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.