W203 Keyfob won't unlock car in the Mornings

classix

New Member
Joined
Aug 15, 2011
Messages
1
Car
C180
Hi i hope someone can help with this.

I have 2 problems and I'm not sure they are related but they are both related to my keys.

I have a C180 W203 2001 I got it a few months ago, it came with 2 keys the first one (silver) worked straight away all of the time. the second one (black) worked to to unlock the doors but not start the car. I have had a look on the forum and it seems this is a common problem with theses keys so I was preparing to get a new key from the stealer's.

about a week ago I went to the car in the morning and it wouldn't open with the silver key i opened the door with the manual key, the alarm went off i was then able to turn it off with the keyfob and start the car, for the rest of the day the key worked fine. This now happens most mornings i go to open the car. i have found if i try to open it and wait about 2 minutes then try again the doors open.

I have changed the battery, when I press the key to open the doors the red light on it flashes and i have tried pointing it at the drivers door handle. If i try the black key after the silver on has failed that fails too. on one occasion i tried the black key first i wasn't able to start the car with either key for about 5 minutes.

I hope that not too much to take in.

Thanks
 

GP801

MB Enthusiast
SUPPORTER
Joined
Jun 18, 2010
Messages
3,087
Location
Sussex and Tuscany
Car
2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
We had the same problem with our 2000 W203 when it was new. Needed a new electronic ignition switch and other bits of the security system replaced. I have heard this is quite a common problem on the early 203s. Hope you have better luck than we did because it took the dealer ages to sort it out but at that time it was a brand new model.
 
Joined
Oct 27, 2011
Messages
30
Location
Liverpool
Car
C220 CDI Sport Coupe
hi guys
i think u have a problem with antenna amp
i had the same problem with my keys and than one day radio didnt tune at all and i could not lock and unlock the car using key fob (both of them ) the new antenna amp costs around £200 and this is what i have paid in march 2011 in my local dealer in liverpool
 

denmrh

New Member
Joined
Sep 30, 2011
Messages
5
Car
E320CDi estate
too many electrical problems

I've had a number of problems with my recently purchased 320cdi which have been posted recently.latest one is that car won't lock at all now using fob aftera number of occasions when it would lock,but all interior lights would come on,along with headlights, and indicators would flash,with no alarm sounding.There was also a noise in the cabin as if a ECU was charging up (or down?),from vicinity of rear pillar,nearside.There seem to be so many gremlins i'm starting to wish I'd gone for a 530 TOURING,instead!.Any advice anyone ?
 

Users who are viewing this thread

Top Bottom