W204 bonnet open warning light- not sensor fault

Discussion in 'Electronics' started by W12RED, Mar 31, 2015.

  1. W12RED

    W12RED New Member

    Messages:
    2
    Joined:
    Mar 31, 2015
    Car:
    W204
    Please Help!!!! C220 Coupe Bonnet Warning light Fault!!

    I have recently repaired my car after i had a bump.

    But for sum reason i can not seem to get the bonnet hood open light off.

    I have replaced every sensor from the bumper to the hinges. i have got rid of every warning light apart from the Bonnet Hood Open.

    My car is currently in dealership which i am getting charged £100 quid an hour :-(
    i dont fink he has any ideas what the fault is.

    He has checked my wiring and there is no fault showing on the MB Star Computer. We have tried manually pushing down the sensor and still no joy.

    Has any one had this issue!! I hoped it was jus a simple sensor fault!! But No!! PLEASE HELP!!
     
    Last edited: Mar 31, 2015
  2. OP
    OP
    W12RED

    W12RED New Member

    Messages:
    2
    Joined:
    Mar 31, 2015
    Car:
    W204
    I have just realised after I remove my airbag module, the bonnet open no longer shows up in my dials??

    Is it possible to code my air bag module to remove the bonnet open function or is there anyway I can bypass it??

    i have checked all my wiring and there is no fault as the bonnet malfunction fault is not coming up
     
  3. richard

    richard Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    5,870
    Joined:
    Jun 10, 2002
    Location:
    Berkshire, UK
    Car:
    MY04 SL55, MY17 GLC250d AMG Sport
    Did you set of an airbag?

    Or did you set off the pedestrian impact stuff on the bonnet that pushes the windscreen end up (and then needs new solenoids to be installed)

    R
     
  4. Toml3

    Toml3 New Member

    Messages:
    2
    Joined:
    Jan 20, 2017
    Location:
    St Neots, Cambridgeshire
    Car:
    C200 CDi & C220CDi & B180 CDi
    W204 Bonnet open warning, but not faulty bonnet sensor

    this is an old posting, but what was the solution?

    I have a 2014 W204 with the same issue, repaired after bump which didnt set off airbags but crash sensor was damaged/replaced. Now bonnet open warning comes up but the bonnet sensor switch is OK.

    ignition position 1 - wipers and washers work OK, no warnings
    ign position 2 - same
    ign start, engine running - no wiper or washers working, no warnings
    drive off - bonnet open warning appears

    I'm running out of things to check, any suggestions please:

    SAM module relays,
    SAM module connectors re-seating?
     
  5. Toml3

    Toml3 New Member

    Messages:
    2
    Joined:
    Jan 20, 2017
    Location:
    St Neots, Cambridgeshire
    Car:
    C200 CDi & C220CDi & B180 CDi
    Update on open bonnet warning W204 2014 model

    UPDATE
    It seems the model I have uses 2 bonnet switches. Not one that is shown in a wiring diagram that is dated around 2012. I did notice the offside switch was not connected into the SAM module at the pin and connector shown in the wiring diagram. I didn't track down where it is connected. Had a switch fitted to nearside catch and working now.
     
  6. Batman123

    Batman123 New Member

    Messages:
    1
    Joined:
    Wednesday
    Location:
    Uk
    Car:
    W204 c class 220 cdi sport
    Hi in regards to ur problem do u have or cud u point me in the right direction for the wiring diagram for said sensors as i am having the same issue? Many thanks in advance
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.