W204 eco mode switch does nothing

Page may contain affiliate links. Please see terms for details.

sceh

Active Member
Joined
Jul 31, 2015
Messages
253
Car
w123 240TD
W204 2011 diesel.
Two weeks ago my eco mode was duff so I changed both batteries and it was fine and worked fine.
Suddenly, when I press the eco button, nothing happens at all. The button doesn't light up and the dash shows nothing.
Any ideas why this has happened?

Thanks
 
Too many prerequisites and that thing when operational is a wrecking ball .
 
W204 2011 diesel.
Two weeks ago my eco mode was duff so I changed both batteries and it was fine and worked fine.
Suddenly, when I press the eco button, nothing happens at all. The button doesn't light up and the dash shows nothing.
Any ideas why this has happened?

Thanks

You'll need to check on STAR (or iCarsoft) to see what it's complaining about.

EDIT:


If you're aircon isn't working, ECO Stop/Start won't work either.
 
You'll need to check on STAR (or iCarsoft) to see what it's complaining about.

EDIT:


If you're aircon isn't working, ECO Stop/Start won't work either.
Thanks - never thought of that. I will get the system refilled and then we'll see.
Good advice!
 
Thanks - never thought of that. I will get the system refilled and then we'll see.
Good advice!
Today I had to change a wheel sensor so I plugged in Carsoft to double check which wheel. I found no faults except the wheel signal so I tried the aircon - worked perfectly as does the ECO mode...go figure!
I will get the system refilled anyway.
 
dumb question, but how?
Sorry, it is not a dumb question, it is me who is dumb. I found out how to do it and the pressure rises to 13 bar with the engine running and the A/C on. Is this good or bad? It implies it works but if so, why did it not work before (yes, I should have measured the pressure when it didn't work but..)
 
Sorry, it is not a dumb question, it is me who is dumb. I found out how to do it and the pressure rises to 13 bar with the engine running and the A/C on. Is this good or bad? It implies it works but if so, why did it not work before (yes, I should have measured the pressure when it didn't work but..)
That's good
 
I keep hearing that the A/C needs to be rest after gas filling. If so, how? Carsoft or is there another way?
 
If it is good, what other conditions would lead the A/C button to blink then stop? I see no fault codes from Carsoft btw
thanks
If the battery is quite low, eg not driven for a while or battery disconnected, can take a reasonable drive before the button will light up and usually needs an engine restart then a further charge for the eco to turn green
 

Users who are viewing this thread

Back
Top Bottom