W204. Noise over speakers from cruise comtrol

Discussion in 'Electronics' started by Freightdog, Jan 13, 2019.

  1. Freightdog

    Freightdog New Member

    Messages:
    3
    Joined:
    Jan 13, 2019
    Location:
    East Midlands
    Car:
    C220 CDi
    Hello, folks.
    Brief intro, I’ve just bought a 2008ish C220 CDi. I’m usually an Audi person, but I needed a car for commuting, wanted, but haven’t owned a Mercedes before, and really liked the C-class. Although I’ll probably head for an E- in a year or so...

    It has a small niggle or two.

    First.
    As per the title. Using cruise control, when speed is reduced there is a crackling breaking through on the audio. A reduction of 1-5 mph gives a short crackle, 10mph or moregives a slightly longer crackle.
    Other than that, it works fine.
    There is no noise when setting the speed initially, accelerating, or re-engaging the cruise control after disconnecting (E.g. after braking)

    I’m using iPhone connected by a long aux input. I am going to be trying the KS Myjack2 for a bit more liberation. I’d like to install a better placed aux socket. The audio system is not bad, but the lack of Bluetooth streaming is a little surprising/disappointing. (A20 system, I think)
    I’m wondering if the noise is to do with the long, unshielded aux cable that I’m using for the moment.

    The other niggles or things to look at will be-
    Audio system. What upgrades/swaps are there that give an integrated Bluetooth music streaming?
    Rear parking sensors not working/detecting.
    Ecu tweak? Worth it?
     
  2. jb1683

    jb1683 New Member

    Messages:
    3
    Joined:
    Jan 6, 2019
    Location:
    Kent
    Car:
    Golf GTD
    Hello! I used to have this exact same quirk with my 2010 C250 CDI. When decelerating with cruise, that was when it was more noticeable.

    It also only happened when I was using Aux mode too.

    It wasn’t very loud so I used to live with it. I think it’s just interference caused by the cruise system- never caused me any issues over 4 years though.


    Sent from my iPhone using Tapatalk
     
  3. OP
    OP
    Freightdog

    Freightdog New Member

    Messages:
    3
    Joined:
    Jan 13, 2019
    Location:
    East Midlands
    Car:
    C220 CDi
    Just a quick follow up. I invested in a KS Myjack2. Bluetooth adaptor. So far, no noise with the cruise control. So it appears the aux cable was picking up some interference.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.