W210 320cdi smoke.

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Well, it seems like the car is taking a dislike to me! Changed the thermostat today, and yes, managed to break the crappy plastic fuel line. Fortunately Drayton had one on the shelf. It is running better now and fuel consumption is better. Problem now is it is black smoking and lacking any real punch. Once it's rolling it goes like a train, but acceleration is lacking. I'm thinking maybe egr/ inlet manifold need a decoke? From what I've read it seems good place to start. Car has done 196,000 miles, injectors have been done before I got it. Any suggestions? Thanks.

Sent from my SM-T365 using Tapatalk
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Think I need weekend head first in the engine bay!

Sent from my SM-T365 using Tapatalk
 

wu56Shoozz

MB Enthusiast
Joined
Jun 17, 2016
Messages
1,982
Location
You'll need a passport to get over the Wall..
Car
MB Vito 111CDi / W203 C Class Saloon 320CDi Avantgarde
Have you tried disconnecting the MAF's see if it runs any better.. If it pulls slightly better without them then your looking at a new Y piece hose with MAF sensors (not sold seperate, come as one @ a stonking £346...fingers crossed mate! :thumb:
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
It had a MAF last year, I have the invoice for it being done at Mainly Mercs in Birmingham. I am wondering if it needs a good decoke? Mileage it's done,it may be worth while.

Sent from my SM-T365 using Tapatalk
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
I know, but not getting any warning lights. This may however be because the bulb for the Check Engine light isn't working and I'm reluctant to replace it as it may tell me things I don't wish to know! Got the ribbon cables and bulbs to do this weekend so will see if the light is on after .

Sent from my SM-T365 using Tapatalk
 

wu56Shoozz

MB Enthusiast
Joined
Jun 17, 2016
Messages
1,982
Location
You'll need a passport to get over the Wall..
Car
MB Vito 111CDi / W203 C Class Saloon 320CDi Avantgarde
When was the last time it was serviced Richard.. I'm asking because mine is a C 320CDi (OM642) therefore has the same engine..so I'm wondering if the fuel filter and Air Filters have been changed.. there was a flaw on the airfilter side of things.. where the air filters choked up real easily due to design..so it may be worth changing filters..Definitely worth getting the codes off it too.. point you in the right direction..

Here's something that may help you...

https://www.bellperformance.com/blog/bid/115989/diesel-engine-problems-black-smoke-explained
 
Last edited:
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Had it serviced as soon as I got it so I knew it was done. I always do when I get another car. Think a code read is in order.

Sent from my SM-T365 using Tapatalk
 

bob6600

MB Enthusiast
SUPPORTER
Joined
Jan 3, 2013
Messages
5,930
Car
AUDI S8 V10, S210 E320 CDI (R.I.P.)
The MAF will not give any light on the dash. If the replacement last year wasn't a genuine Pierburg then I would replace it, the cheap ones are crap.

Best thing is to check the pipes and if they are ok, get a good diagnostic done, preferably on STAR.

This could be a number of thing including sticky EGR, MAF, split boost pipe so you really are guessing

EDIT: Oh and have a read here

https://www.mbclub.co.uk/forums/engine/144927-lack-power-cdi-what-do.html
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Unusual development this evening. Did my usual fortnightly round trip from Burton-on-Trent to Macclesfield. On the way the car was still smoking under load but otherwise ok. On the way back I had to pull out a bit sharper than normal and suddenly it see to have loads more power, it chucked out a big cloud of black smoke and went like a train all the way home with hardly any smoke and more power. The only change has been the thermostat replacement on Friday. Fuel consumption was drastically better, achieving just under 42 mpg on the round trip. This included a childish race with a Golf GTI on the way ,seeing him off as well. Any thoughts on what may have decided to clear?


Sent from my SM-T365 using Tapatalk
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
It is on a tank full with forte in at the moment. May run one more through as I don't know how long it's been running cold because of the thermostat.

Sent from my SM-T365 using Tapatalk
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Does the mpg seem about right? Still getting used to it, although it seems better than I expected.

Sent from my SM-T365 using Tapatalk
 

bob6600

MB Enthusiast
SUPPORTER
Joined
Jan 3, 2013
Messages
5,930
Car
AUDI S8 V10, S210 E320 CDI (R.I.P.)
Yes MPG seems about right, failed thermostat can cause it to drop
 

coneybiller

Active Member
Joined
May 11, 2016
Messages
195
Location
Cheltenham
Car
S210 320cdi Avantgarde 02'
My W210 E320cdi seems to be a lot better, after a big faff under the bonnet changing the bonnet cable! I'm beginning to think the inlet pipe from the grille to the airbox wasn't fitted correctly. I've heard of this issue before, where it collapses under heavy throttle. This will cause a lack of power and black smoke. Will be worth a check and an easy fix if that is indeed the case! Also check the boost hose, inlet and outlet of the intercooler. If 1 of these has a tiny tear in, that will also give you your lack of power and black smoke. Get your head under the bumper and find the hoses (usually the 1s covered in oil). Get someone to rev the engine while u grab hold of the pipes. You'll know pretty quick if its split (oh and don't go near the fan or the belt!!)!
 
OP
OP
Richard1973

Richard1973

Active Member
Joined
Mar 4, 2017
Messages
211
Car
S210 320cdi Avantgarde
Before I go poking around I was thinking of steam cleaning the engine bay as it has years of grime in there. Never had a problem doing this on other cars, is there anything to avoid ?

Sent from my SM-T365 using Tapatalk
 

bob6600

MB Enthusiast
SUPPORTER
Joined
Jan 3, 2013
Messages
5,930
Car
AUDI S8 V10, S210 E320 CDI (R.I.P.)
Before I go poking around I was thinking of steam cleaning the engine bay as it has years of grime in there. Never had a problem doing this on other cars, is there anything to avoid ?

Sent from my SM-T365 using Tapatalk
Cover the electrics with bags and avoid the relay and fuse boxes. Cover the alternator too.
 

Auto-mobile

MB Enthusiast
Joined
Oct 1, 2011
Messages
1,600
Location
Birmingham
Car
2x c43 Amg clio 172 turbo 314bhp
Have you tried disconnecting the MAF's see if it runs any better.. If it pulls slightly better without them then your looking at a new Y piece hose with MAF sensors (not sold seperate, come as one @ a stonking £346...fingers crossed mate! :thumb:
Wrong engine.


You could have a leak in a boost hose or the intercooler, either get your fault codes read or remove the egr valve and give it a good clean.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom