w210 estate rear door noise

Discussion in 'Bodywork' started by 2117kh, Jul 11, 2011.

  1. 2117kh

    2117kh New Member

    Messages:
    19
    Joined:
    May 26, 2011
    Location:
    LIncoln U.K
    Car:
    r107 350sl
    Hi All

    I have , as they probably all do, self closing mechanism in rear door of my estate.
    When you close it should it sounds like somethings fell off?...it works okay but sounds awful...no mercedes clunk here, more of a clank..difficult to describe exactly but it happens every time

    any ideas?
     
  2. renault12ts

    renault12ts MB Club Veteran

    Messages:
    15,793
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    Yes. It's normal.
     
    1 person likes this.
  3. Working my Merc

    Working my Merc Member

    Messages:
    48
    Joined:
    Jul 1, 2011
    Car:
    E320 CDi Estate
    I have to admit that mine is a W211 but that does not sound good to me. Has it just started doing it or is it something you have suffered for a while?
     
  4. OP
    OP
    2117kh

    2117kh New Member

    Messages:
    19
    Joined:
    May 26, 2011
    Location:
    LIncoln U.K
    Car:
    r107 350sl
    re back door

    Hi
    I have had the car since january and it has always done it..sounds like something has fallen off when you shut the door, like a plunger...works okay but its like there should be a buffer or something for the mechanism to strike if thats what it does..I really dont want to take it apart unless there is a known cure because that tailgate panel is a b###ch to get back on again. This is from experience after repalcing washer pipe a couple of times.

    thanks for your interest kh
     
  5. Harrythedog

    Harrythedog Hardcore MB Enthusiast

    Messages:
    1,945
    Joined:
    May 8, 2011
    Location:
    Tynemouth
    Car:
    GLC 250 Sport Premium+
    Mine reminds of the sound you use to hear when you put a video tape into the machine but it works fine
     
  6. renault12ts

    renault12ts MB Club Veteran

    Messages:
    15,793
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    See post 2...it's normal. I've had 2, they both sounded the same.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.