W211 220 CDI: Oil-burner ?

yngve

New Member
Joined
Aug 28, 2004
Messages
1
Bougt me a new 220 CDI in Sweden, april 2003.
Lots of trouble the first 4 months :
11 liters of engine oil in 8.000 km and a new engine.
Lots of emrgency mode.
The work shop said: You ned a new engine, but the
Norwgian distributor said : No, this will be OK after some
time. So they put a new turbo in it, but then the oil
consumption raised from 1 litre/1000 km to 5 litres/ 700 km.
So, they ordered a new engine from Germany in July.
The engine arrived the workshop, and stayed beside my car
in the workshop for one week. Then they said : Sorry, we can't
do the job before the holyday is over in 2 weeks time.
Do I have to wait for 3 weeks and driving arrond in a bad A-class ?
The Norwegian distributor got my story, and asked med :
Do you expect us to solve your problems with you local dealer ?
Well, I hope you do. Two days after got my 220 CDI back with
the new engine.
After this I got lots of "display failures", and after some more
visits at my local dealer, they replaced a complete display.
- Not a happy story, but the last 8 months have been normal.
My first service was a "C-service" at 44.000 km- not bad ?
Happy former beetle-driver
Yngve
 

marcos

MB Enthusiast
Joined
Oct 6, 2003
Messages
1,313
Location
Hertfordshire
Car
C43 estate
I'm not sure whats stranger Yngve, your car problems or your description of problems. :confused: :confused: :confused:
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Lets hope now that you have got rid of that "Friday Engine" everything will be OK. :D
 

Users who are viewing this thread

Top Bottom