W211 (E320) )M642 - lack of power

Discussion in 'Engine' started by David404, Aug 19, 2017.

  1. David404

    David404 Active Member

    Messages:
    751
    Joined:
    Sep 7, 2015
    Location:
    West Midlands
    Car:
    GLE350d (W166)
    Driving back from Devon today car lost power, not misfiring, no horrid noises but severe lack of power, wont run past 3000RPM and NO EML or any other warning lights on.

    when up to speed it runs along just fine you wouldn't know there was anything wring its only on opening the throttle that there's any evidence of a fault.

    Off to the workshop on Monday but anybody with any ideas, any common issues?
     
  2. 4life211

    4life211 Active Member

    Messages:
    293
    Joined:
    Jul 14, 2015
    Car:
    mercedes 211
    First thing to do is : reading the codes stored in board.Then to see to do .
     
  3. SL300-24

    SL300-24 MB Enthusiast

    Messages:
    1,738
    Joined:
    May 28, 2004
    Location:
    Essex
    Car:
    2007 CLS 320CDI,1984 500SL, 2007 E320 CDI Sport Estate, 1991 230TE
    Does it clear once you turn it off and restart?
     
  4. OP
    OP
    David404

    David404 Active Member

    Messages:
    751
    Joined:
    Sep 7, 2015
    Location:
    West Midlands
    Car:
    GLE350d (W166)
    Seems OK for a short time but by tie engine is warm fault is back.

    The EML is NOT and has NOT been on.
     
  5. 4life211

    4life211 Active Member

    Messages:
    293
    Joined:
    Jul 14, 2015
    Car:
    mercedes 211
    No eml?? Sounds like transmission problems.
     
  6. OP
    OP
    David404

    David404 Active Member

    Messages:
    751
    Joined:
    Sep 7, 2015
    Location:
    West Midlands
    Car:
    GLE350d (W166)
    That was my first thought as first time I noticed it was when I accelerated (or tried to) away from some slow traffic it didn't downshift. but even allowing for the lack of downshift it should have pulled away faster. With foot on the floor the revs were rising very very slowly. In manual mode it changes up and down fine but wont rev to over 3000.
     
  7. Azeem

    Azeem Active Member

    Messages:
    156
    Joined:
    Feb 1, 2016
    Location:
    Pakistan
    Car:
    W211 E270 cdi - 2003
  8. OP
    OP
    David404

    David404 Active Member

    Messages:
    751
    Joined:
    Sep 7, 2015
    Location:
    West Midlands
    Car:
    GLE350d (W166)
    Will see tomorrow, will pop into my regular Indie and see if they can fit me in. The link Azeem posted is pretty much were I am so looks like something on the air intake side of things. Hoping its not too much £££.

    Helpfully the EML had today decided to illuminate.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.