W211 E320CDi gearbox issue?

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
Hi all.I have searched through the forum but haven't found an answer, which I hope does not mean that my problem is going to be hard to find / fix....
Several times recently when we have started the car from cold, first thing in the morning, we have noticed that we cannot select D (drive). It is as though the foot-brake isn't depressed and the shifter is locked in P.
Can anyone suggest any ideas please? I am hoping that it is simply a gearbox fluid change that is required. The car is a 2005 (55) E320, CDi with G7 box and has just tripped over to 200,000 miles. I am unsure when the last gearbox service was carried out, if ever.....
TIA

Keith
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Hi all.I have searched through the forum but haven't found an answer, which I hope does not mean that my problem is going to be hard to find / fix....
Several times recently when we have started the car from cold, first thing in the morning, we have noticed that we cannot select D (drive). It is as though the foot-brake isn't depressed and the shifter is locked in P.
Can anyone suggest any ideas please? I am hoping that it is simply a gearbox fluid change that is required. The car is a 2005 (55) E320, CDi with G7 box and has just tripped over to 200,000 miles. I am unsure when the last gearbox service was carried out, if ever.....
TIA

Keith
Keith

There is an interlock that stops you selecting D etc without pressing the brake pedal, it could be this switch? I assume your brake lights are fully operational?

Can you move the lever to D from cold with the engine off before you start it? If you have no idea when the gearbox was serviced I would also see this as a priority regardless of what else may be wrong.
 
OP
OP
mr tibbs

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
Thanks for the advice DSM10000. It will be getting the box serviced as soon as we can book it in. Can't answer your questions, but in the morning I will try to get into D before starting and get my wife to check the brake lights are coming on at the same time.

Keith
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Thanks for the advice DSM10000. It will be getting the box serviced as soon as we can book it in. Can't answer your questions, but in the morning I will try to get into D before starting and get my wife to check the brake lights are coming on at the same time.

Keith
Good luck Keith.

There have been issues known with the selector mechanisms, there are some electronics in there, has anything been spilt over the gear lever area? If not it may be worth removing it and using electrical contact cleaner.

How is the battery voltage first thing before engine start?

David
 

clk320x

Hardcore MB Enthusiast
SUPPORTER
Joined
Sep 27, 2016
Messages
10,342
Location
East Midlands
Car
W212 E250 CDI Sport - S211 E320 CDI Avantgarde - S203 C32 AMG
has anything been spilt over the gear lever area?
Uh oh... I spilt a Coca-Cola can over mine just 2 days ago :oops::eek:

Seems fine though thankfully, no ****ing cup holders!
 
OP
OP
mr tibbs

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
I am not aware of any spills, I am to tight to spill my coffee ;)
I will also check battery voltage as well, I guess that with the slightly cooler mornings this is the time of year that will test an old battery...
Thanks for your help :)

Keith
 
OP
OP
mr tibbs

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
Morning all. I have just been out to the car to make a couple of checks. Firstly I switched on the ignition but didn't start the engine. Applied the foot brake and pulled the selector down from P and it stopped before D. Went back to P and back to P and it went in fine. Tried a couple more times and found that intermittently it didn't want to go into D....
Maybe a mechanical adjustment?
Checked battery voltage and found 12.20 Volts, so a bit low I think and it is a tad cool this morning here in Costa Del Desborough :)
Any thoughts please?

Keith
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Good morning Keith

I think the selector is just a switch, the only electro-mechanical part is the interlock, perhaps it is partly re-engaging once released?

I would be tempted to remove the selector and check and clean all electrical connections first. Substituting another gear selector panel would also be a good way of fault elimination, do you know of anyone with a similar car? Failing that a good MB independent should quickly find the issue.

David
 
OP
OP
mr tibbs

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
Hi David.
Yes thanks for that. I believe that the battery is past its best and will get it replaced. I will ask the garage to check the selector at the same time.
We have also had intermittent starting issues recently, like waiting for the glow plug lamp to go out, turning the key and the engine fires after several rotations, it usualy fires up almost instantly, so this could be low battery dependent... We had new glow plugs fitted a couple of years ago, so I can't see the problem being that and as we are now experiencing other issues, I am inclined to think that the battery is fubarred. ;)
Thanks again for your guidance.

Keith
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Hi David.
Yes thanks for that. I believe that the battery is past its best and will get it replaced. I will ask the garage to check the selector at the same time.
We have also had intermittent starting issues recently, like waiting for the glow plug lamp to go out, turning the key and the engine fires after several rotations, it usualy fires up almost instantly, so this could be low battery dependent... We had new glow plugs fitted a couple of years ago, so I can't see the problem being that and as we are now experiencing other issues, I am inclined to think that the battery is fubarred. ;)
Thanks again for your guidance.

Keith
Keith

I am assuming you have an early V6 if you have the 7 speed box? ?

At this time of year the glow lpugs should hardly be needed, it could be that the glow plug control unit is faulty although this would not explain the gear selector issue!
 

Joesoap17

Active Member
Joined
Nov 26, 2017
Messages
278
Location
Essex
Car
S211 220CDI 2008, Jaguar XK8 4.2 2002
Could something solid have got inside the selector mechanism?
It sure seems like it is a mechanical issue and sounds as if it is baulking just before you get to D!
 
OP
OP
mr tibbs

mr tibbs

Active Member
Joined
Jun 19, 2013
Messages
222
Location
Desborough, Northants
Car
S211 E320 Estate
Hi David. Not sure if the car is an early model or not, it is a 55 registered car if that means anything. I agree with your comment re glow plugs but we always wait for the lamp to extinguish before starting. I charged the battery yesterday and got a reading quite soon after charging of 13.5 volts. I haven't been able to check it this morning as I had to go to the dentist to have 3 teeth removed (ouch) :) however the car started faultlessly and went into drive first time, so that battery is looking really suspect.
I read somewhere on here that these W211 cars have a second battery, is this correct and if so do you know where it is located please?
Hey Joe, that thought had occurred to me also, however with it being intermittent and just in the last few days, I am inclined to think the battery is the culprit for several silly glitches recently and will get it replaced as a matter of course.
As I have not been able to find any indication of a gearbox service or fluid change in the service documentation, which is pretty comprehensive, I will have that attended to at the same time as the battery and treat it to a full service at the same time :)
Thanks for all the help and advice, I will report back when my wallet is appropriately lightened....
Thanks

Keith
 

DSM10000

MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
7,037
Location
Near Salisbury
Car
E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
Hi David. Not sure if the car is an early model or not, it is a 55 registered car if that means anything. I agree with your comment re glow plugs but we always wait for the lamp to extinguish before starting. I charged the battery yesterday and got a reading quite soon after charging of 13.5 volts. I haven't been able to check it this morning as I had to go to the dentist to have 3 teeth removed (ouch) :) however the car started faultlessly and went into drive first time, so that battery is looking really suspect.
I read somewhere on here that these W211 cars have a second battery, is this correct and if so do you know where it is located please?
Hey Joe, that thought had occurred to me also, however with it being intermittent and just in the last few days, I am inclined to think the battery is the culprit for several silly glitches recently and will get it replaced as a matter of course.
As I have not been able to find any indication of a gearbox service or fluid change in the service documentation, which is pretty comprehensive, I will have that attended to at the same time as the battery and treat it to a full service at the same time :)
Thanks for all the help and advice, I will report back when my wallet is appropriately lightened....
Thanks

Keith
Keith

Is your car a facelift W211 of pre-facelift?

Facelift have the angular front bumper amongst other features.

Pre-facelift had two batteries and a battery control unit. Either battery can cause faults as can the control unit. Facelift cars have a single battery in the boot.
 

clk320x

Hardcore MB Enthusiast
SUPPORTER
Joined
Sep 27, 2016
Messages
10,342
Location
East Midlands
Car
W212 E250 CDI Sport - S211 E320 CDI Avantgarde - S203 C32 AMG
I don't know if our car is pre facelift or not tbh. It does have a large battery in the boot though
Does the front end look identical to mine? In which case it’s a pre-facelift :)

Mine is also a 55 plate btw. Also with 200K+ miles ;)

View media item 7905
 

E55BOF

MB Enthusiast
SUPPORTER
Joined
Mar 11, 2013
Messages
6,467
Location
South Bucks
Car
S211 E500, SLK55, ML420 CDI, FJR1300, Caponord
Facelift was for the 2006 model year.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom