w211 parking sensors not working

Discussion in 'Electronics' started by slik_sly, Jun 30, 2011.

  1. slik_sly

    slik_sly Active Member

    Messages:
    112
    Joined:
    Dec 3, 2007
    Front lights come on
    You can hear a beeps but the sensors don't work!

    Any idea where to start?
     
  2. rascalmaster

    rascalmaster MB Enthusiast

    Messages:
    1,407
    Joined:
    May 5, 2010
    Location:
    harwich, essex. UK
    Car:
    Brabus D5 (E280 CDI) Avantgarde, E280 CDI Sport Estate, E320 Avantgarde now sold
    U've not got gunk around them have you?
    After an overzealous wash n wax I was having trouble; till I cleaned the sensors with earbuds...
     
  3. hercules

    hercules Active Member

    Messages:
    227
    Joined:
    Dec 7, 2002
    Location:
    Kent
    Car:
    W203 2006 180K Sport Edition & ML164 sport
    Worth checking for build-up mud around the sensors !!
     
  4. Diesel Benz

    Diesel Benz MB Enthusiast

    Messages:
    4,088
    Joined:
    Feb 3, 2006
    Location:
    Europe
    Car:
    222.132 & 221.122 & 213.050 & 906.633
    If it isn't dirt, then a sensor or a few are broken. Do get a beep and two red leds on the display (for each side), either for the front or the rear, or both?
     
  5. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,855
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, E55 AMG, S500, etc
    Get it on a Star. One or more sensors are probably faulty
     
  6. John

    John Hardcore MB Enthusiast

    Messages:
    12,179
    Joined:
    Mar 3, 2011
    Location:
    Daan Saaf
    Car:
    I wish.
    If it is the dreaded prolonged two beeps, it might be water in them.

    When I first got mine, the slightest rain made them do it.

    How handy Mercedes had the foresight to put a button right by your left hand to switch them off - it's almost as if they knew they would be ****!

    Anyhow, they must have dried out somewhat as they now only do it when it has rained for a while.

    I found this on another forum which I am going to have a go at - might be useful...

    Park Sensor Fixed - Mercedes-Benz Owners' Forums
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.