W211 Starting Problem

Discussion in 'Engine' started by jeev2008, Jul 19, 2008.

  1. jeev2008

    jeev2008 New Member

    Messages:
    13
    Joined:
    Jan 2, 2008
    Got an E320 Petrol that has covered 115k

    THe engine management light came on whilst driving it however nothing was noticeable at the time... however if its driven after having a long period of rest it starts fine

    however if you have a short start - stop journey then attempt to start the car again it fails... and takes about 3 attempts of turning the key before it starts...... engine management light is still on now.

    Any ideas what it could be?
     
  2. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    Possible crank sensor, but that doesn't normally bring on the light. have the codes read.
     
  3. OP
    OP
    jeev2008

    jeev2008 New Member

    Messages:
    13
    Joined:
    Jan 2, 2008
    Anyone got a code reader im in surrey?
     
  4. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
  5. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,412
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    crank position sensor wont register a fault code..
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.