W212 Command Issues

Page may contain affiliate links. Please see terms for details.

W212Chris

Active Member
Joined
Sep 18, 2023
Messages
83
Location
Lincolnshire
Car
W212
Completely lost now with this issue.
W212 Command does not work at all. The screen is dead with no Mercedes Logo on bootup, or any other systems i.e. Radio, Sat Nav etc etc.
I have tried the physical reboot CD Eject 10 seconds button
I have removed the battery - placed on charge over night and is working well.
Checked all the fuses - no issue there
I have signs on the dashboard that the Satnav, Radio, Telephone options are available, but the screen remains blank.
I have checked the Modules Rear fuse and that too is fine.
I have also checked / replaced the Aux battery but still nothing.
Can anyone else point me in the right direction to fault find this please ?
Chris
 
Completely lost now with this issue.
W212 Command does not work at all. The screen is dead with no Mercedes Logo on bootup, or any other systems i.e. Radio, Sat Nav etc etc.
I have tried the physical reboot CD Eject 10 seconds button
I have removed the battery - placed on charge over night and is working well.
Checked all the fuses - no issue there
I have signs on the dashboard that the Satnav, Radio, Telephone options are available, but the screen remains blank.
I have checked the Modules Rear fuse and that too is fine.
I have also checked / replaced the Aux battery but still nothing.
Can anyone else point me in the right direction to fault find this please ?
Chris
I would start by removing the unit and checking there is 12v getting to it.
 
I would start by removing the unit and checking there is 12v getting to it.
Alfie,
thanks again for the suggestion. I was just about to approach you guys on further advice regarding the current Screen and system. The upgrade to Android/Apple option is avaialable to me with a larger screen/reversing camera.
 

Users who are viewing this thread

Back
Top Bottom