W212 E63 AMG suspension noise from OS?

AlexM

Active Member
Joined
Oct 4, 2005
Messages
325
Location
Kingston upon Thames
Car
W212 E63 AMG Saloon
My E63 is currently at the dealer for investigation of a light knocking/tapping noise that is most noticeable when the car is cold. So far the arb drop links have been changed, as have the lower suspension arms (thankfully under warranty), but the problem remains. No obvious problems visually - what else is it likely to be? A problem with the strut? Anti roll bar bushes? Top mounts?. The car has done 23k and is a 2013 model.

Any suggestions?

Thanks,
Alex
 

HB

MB Enthusiast
SUPPORTER
Joined
Mar 30, 2011
Messages
2,933
Car
C63 , E350 CDI, C320 CDI, SQ7
We had a similar problem at a similar mileage - both front top mounts believe or not.
 
OP
OP
A

AlexM

Active Member
Joined
Oct 4, 2005
Messages
325
Location
Kingston upon Thames
Car
W212 E63 AMG Saloon
We had a similar problem at a similar mileage - both front top mounts believe or not.
That's interesting. I did have to have one of the top mounts greased as it was making a squeeking noise as lock was wound on or off. That was also on the driver's side that the knocking/tapping appears to be coming from. Is there an easy way to check the top mounts?

Regards,
Alex
 
OP
OP
A

AlexM

Active Member
Joined
Oct 4, 2005
Messages
325
Location
Kingston upon Thames
Car
W212 E63 AMG Saloon
surprise, surprise, I got the car back without any diagnosis - no fault found, and heard the noisie within a couple of hundred metres driving away.

In fairness to the dealer, they did invite me to bring it back if I could find a way to make the problem apparent. We'll have to see if it becomes more apparent. The nature of the noise is a light knocking noise when the wheel is in bump/droop. ARB drop links and lower susupension arms were replaced under warranty due to deterioration (which is suprising in a just three year old car). MB made a 70% contribution to the warranty company, which is interesting. I wonder if there is a known issue with the inboard bushes on the lower suspension arms?.

Admittedly I am being very fussy, but I can definately hear something and I don't think suspension should knock/tap over bumps.

Regards,
Alex
 

sjmaxwell

MB Enthusiast
SUPPORTER
Joined
Aug 15, 2003
Messages
3,371
Location
Chatham, Kent
Car
2012 E Class E63 PPP, 2012 SLK55 AMG
Did you get this resolved? Only ask as mine is in the dealers for a vibration issue when going over 80mph (there is a Xentry doc on this problem since 2010) but I also have this knocking when going slow over rougher surfaces. As there is no fix yet, Mercedes Technical have been guiding the dealer in fitting modified top mounts and other components and asked if I can fill a document in about how it performs. I'm guessing they are assessing how different changes are effecting the issue to see if a permanent resolution can be found :thumb:
 
OP
OP
A

AlexM

Active Member
Joined
Oct 4, 2005
Messages
325
Location
Kingston upon Thames
Car
W212 E63 AMG Saloon
Did you get this resolved? Only ask as mine is in the dealers for a vibration issue when going over 80mph (there is a Xentry doc on this problem since 2010) but I also have this knocking when going slow over rougher surfaces. As there is no fix yet, Mercedes Technical have been guiding the dealer in fitting modified top mounts and other components and asked if I can fill a document in about how it performs. I'm guessing they are assessing how different changes are effecting the issue to see if a permanent resolution can be found :thumb:

No still not resolved yet unfortunately. I think that the problem is drivers side top mount or the strut on that side. Can you share any information about the fix or the documents in Wis / xentry you mention?. Dealer says they can't hear anything untoward but I can pretty clearly. It sounds like a ball joint or similarly light sounding rattle.

Any info on your case or how you initiated an investigation would be most welcome as it is still niggling me.

Regards,
Alex
 

sjmaxwell

MB Enthusiast
SUPPORTER
Joined
Aug 15, 2003
Messages
3,371
Location
Chatham, Kent
Car
2012 E Class E63 PPP, 2012 SLK55 AMG
No still not resolved yet unfortunately. I think that the problem is drivers side top mount or the strut on that side. Can you share any information about the fix or the documents in Wis / xentry you mention?. Dealer says they can't hear anything untoward but I can pretty clearly. It sounds like a ball joint or similarly light sounding rattle.

Any info on your case or how you initiated an investigation would be most welcome as it is still niggling me.

Regards,
Alex
Its just back from the dealers and seems much better due a new modified top mounts (they are the same as the facelift model) and other parts that the dealer didn't list but they didn't all come in together so ended up another day in their workshop.

Xentry doc attached
 

Attachments

Last edited:
OP
OP
A

AlexM

Active Member
Joined
Oct 4, 2005
Messages
325
Location
Kingston upon Thames
Car
W212 E63 AMG Saloon
Thanks for that. Interesting Tips case, although presumably not relevant to me given my car is a face-lift model. I did have tremendous problems with high speed vibration, although this turned out to be out of limit road force imbalance that was resolved by replacing the tyres. My front top mounts required remediation under warranty for squeaking / screeching when applying lock while parking. I believe this is fixed with a new type of grease (at least temporarily)

Regards,
Alex

Sent from my ONEPLUS A3003 using Tapatalk
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom