W215 - iCarSoft MB V2.0 can't connect to ODB

TimGow

New Member
Joined
Jul 10, 2012
Messages
20
Car
W215 CL500
Hi,
I've tried the iCarSoft MB V2.0, it runs dianostics ok but won't connect to the ODB.
Communication error / Link error, Check 1.cable, 2.ign on, 3.ODBII compliant
The car won't start and the radiator fan comes on running full.
Is the ODB comms error suggesting any particular fault?
Could it be that the ECU isn't powered up? Is the a fuse for the ECU?
Any help really welcome please.
 
OP
OP
T

TimGow

New Member
Joined
Jul 10, 2012
Messages
20
Car
W215 CL500
KliierHERTZ,
I've updated the scanner but still the same, comms error. Do you know what I can check next?
 
OP
OP
T

TimGow

New Member
Joined
Jul 10, 2012
Messages
20
Car
W215 CL500
Central gateway module? Could that cause the radiator cooling fan to roar in the engine run key position but no starting plus no ODB comms?
 

pillow

Active Member
Joined
Feb 19, 2019
Messages
157
Location
Hampshire
Car
W216 CL600
Hi,
I've tried the iCarSoft MB V2.0, it runs dianostics ok but won't connect to the ODB.
Communication error / Link error, Check 1.cable, 2.ign on, 3.ODBII compliant
The car won't start and the radiator fan comes on running full.
Is the ODB comms error suggesting any particular fault?
Could it be that the ECU isn't powered up? Is the a fuse for the ECU?
Any help really welcome please.
I'm pretty sure radiator fan on full is what happens when there is an ECU fault.
 
OP
OP
T

TimGow

New Member
Joined
Jul 10, 2012
Messages
20
Car
W215 CL500
pillow,
Thank you, I'll find the ecu and check that it is getting power, fuse etc.
 
OP
OP
T

TimGow

New Member
Joined
Jul 10, 2012
Messages
20
Car
W215 CL500
Hi,
Is there a wiring diagram available online for the W215/CL500?
 

Users who are viewing this thread

Top Bottom