W220 Aircon not working?

Bladerunner2125

Active Member
Joined
Apr 21, 2012
Messages
79
Car
S320 W220 2002
My Aircon has stopped working, did have the water problem coming into the car via the blocked drain under the windscreen carpet wet in the foot well, cleaned the blocked drain and let the water out, then noticed a few days later that Aircon was not working and the Red Aircon off light was lit all the time, was also getting a squeaky Blower fan.

Have had a look at the Aircon NR Readings using the two buttons (Cabin Filter & Rest) got an Error 1256 from the error readings?

Removed the Heater Blower to have a look at it, noticed that a bit of moisture had caused a little corrosion around the base of the shaft this was the cause of the squeak cleaned that up and oil and greased it lightly, the blower works fine now no squeaks but Aircon is not coming on no change in temperature when using the AC button also used to be able to hear the Aircon change the note of the engine when on, can't hear that anymore so thinking its just not working?

NR Readings as follows

NR.00 - +23.4 °C
NR.01 - +22.5 °C
NR.02 - +18.0 °C
NR.03 - +20.6 °C
NR.04 - +20.4 °C
NR.05 - +19.9 °C
NR.06 - +78.0 °C
NR.07 - 6.0 Bar (Engine Running Aircon light off )
NR.08 - +18.8 °C
NR.09 - -2.4K
NR.10 - 1.6V
 
Last edited:

219

MB Club Veteran
Joined
Aug 19, 2002
Messages
15,664
Location
Gone
Car
Not always
When was it last regassed?

This is the first thing to try , but you may have a leak .
 
OP
OP
B

Bladerunner2125

Active Member
Joined
Apr 21, 2012
Messages
79
Car
S320 W220 2002
(Update) The water getting into the car was just a coincidence, the Blower had seen some of the water but the reason the Aircon wasn't working was because there was hardly any Gas in the system, had it recharged, now its nice and cold again.
 

Norte23

Active Member
Joined
Aug 8, 2016
Messages
124
Location
Cheshire
Car
C250 AMG Sport Avantgarde 2010
Cool. Glad you got it sorted.

Mark
 

Users who are viewing this thread

Top Bottom