W221 S320 cdi intermittent hesitation on acceleration

Mow221

Active Member
Joined
Jan 6, 2020
Messages
70
Location
In the garage!!
Car
W221,W212,w211,W209,s211
I know this has probably been posted a thousand times before....
When I bought my s320 CDI 2007 it had a slight hesitation intermittently.
the car has high mileage, 430km roughly 250k mile...
but has had quite a good history most of its life.
I knew i had issues with leaks etc, so i did all the usual necessary repairs.
Oil cooler seals in the v...
During the repair I carried out all the other related issue repairs, PCV, manifold flap motor and new rods, all gaskets and seals renewed, turbo tested, new core, and motor and flow tested, egr valve etc.
basically I didn't want to be going back in there again anytime soon...

After the repair everything went back together as it should, cleaned down and drove great.
But again intermittently there is a hesitation, doesnt have to be cold or hot, not necessarily from a standstill, can just happen as you drive and try accelerate, feels like its pulling back then lets go, i was sure it was a sticking egr valve of restricted fuel filter??? but it has me baffled, at the moment there are no dtcs stored and has done this on a few occasions now.

I know im not giving much to work with but just might be something silly that im missing?
Also changing through gears manually doesnt make a difference and there are no trans dtcs logged...

ECM sw is showing software status 05/06, would it be a case it needs or might take a SW upgrade??

Any help is much appreciated...

Mark.
 
OP
OP
Mow221

Mow221

Active Member
Joined
Jan 6, 2020
Messages
70
Location
In the garage!!
Car
W221,W212,w211,W209,s211
Yes and from reading of similar issues I was trying to rule that out as I had the turbo redone with new motor fitted also... I hope it's not, as that would be extremely disappointing!
 
OP
OP
Mow221

Mow221

Active Member
Joined
Jan 6, 2020
Messages
70
Location
In the garage!!
Car
W221,W212,w211,W209,s211
Took out for a drive today, looking at graphs to see if i can catch whats dropping off during hesitation, nothing definite yet? hard to pin point this one... did have a bit of a fuel leak from the cross over pipe due to it not being tightened up correctly!:wallbash::rolleyes:
 
OP
OP
Mow221

Mow221

Active Member
Joined
Jan 6, 2020
Messages
70
Location
In the garage!!
Car
W221,W212,w211,W209,s211
A little job this evening, noticed when I was doing the other work one of the injector washers wasn't sealing causing compression to blow past, looks like for a while possibly, with a fair amount of carbon buildup around the injector.
First step was to move parts out of the way, airbox, intake pipe and sound deadning. Then to open the injector pipe on the injector side without doing damage to the return pipe.
So I made up a few special tools to do the job, didn't have a deep open crows foot socket and an open end spanner came too close to the return pipe and the injector connector. So I made a nice easy tool to crack the nut, see below.
Then the extraction of the carboned up injector.... Made a handy little slide hammer with a bike engine bold a weight and a wheel nut...
Pulled the Injector and no damage done, and washer is removed to be replaced with a new one and refitted, at least one job going to plan this week....
 

Users who are viewing this thread

Top Bottom