w221 S320cdi white/blue smelly smoke / poor fuel economy

Sparkzz

New Member
Joined
Jan 26, 2016
Messages
2
Car
W221
Hi Guys,

I've had my S class for about a year now and have noticed from the start there is substantial white smoke on cold starts or when sitting in traffic. The smoke stinks and I can only imagine it is diesel which isn't being burned.

I know from the previous owner that the car had the problem with the inlet port shut off motor, but this was repaired by Mercedes.

The car shows no faults on STAR and doesn't use any oil or water.

I am also struggling to get good fuel consumption, my commute I barely manage 28MPG over 13 miles. This is mostly A roads at 50MPH.

I've just had to replace a brake caliper and control arm, which wasn't cheap either. To make matters worse, now the steering wheel isn't holding straight, so I'll be going back tomorrow to let the garage know.
 

Borys

MB Enthusiast
Joined
Feb 16, 2011
Messages
1,764
Location
Nowe nad Wisla
Car
2005 cl500
Check my treads
Had similar issue with mine
Unfortunetally I gave up in the end, ruterned the car to dealer-issue was never fixed
 

John

Hardcore MB Enthusiast
SUPPORTER
Joined
Mar 3, 2011
Messages
12,359
Location
Daan Saaf
Car
I wish.
Where are you based?

Time to find a reputable inde methinks - and take a trip to WIM in Chesham to get the geometry sorted.
 
OP
OP
S

Sparkzz

New Member
Joined
Jan 26, 2016
Messages
2
Car
W221
Im in the north east. Durham/Newcastle.

Is it normal for the wheel to be misaligned after control arm replacement or have they done it wrong?
 

Linus.PL

New Member
Joined
Jan 26, 2012
Messages
10
Car
W221 '07 S320CDi
Im in the north east. Durham/Newcastle.

Is it normal for the wheel to be misaligned after control arm replacement or have they done it wrong?
Hi,
no this is not normal. That happens when job was done careless.
Kind regards
 

Linus.PL

New Member
Joined
Jan 26, 2012
Messages
10
Car
W221 '07 S320CDi
Hi Guys,

I've had my S class for about a year now and have noticed from the start there is substantial white smoke on cold starts or when sitting in traffic. The smoke stinks and I can only imagine it is diesel which isn't being burned.

I know from the previous owner that the car had the problem with the inlet port shut off motor, but this was repaired by Mercedes.

The car shows no faults on STAR and doesn't use any oil or water.

I am also struggling to get good fuel consumption, my commute I barely manage 28MPG over 13 miles. This is mostly A roads at 50MPH.

I've just had to replace a brake caliper and control arm, which wasn't cheap either. To make matters worse, now the steering wheel isn't holding straight, so I'll be going back tomorrow to let the garage know.
I got the same issues, maybe except fuel consumption but not monitoring it a lot.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom