W245 B170 Radiator Fan staying on

Discussion in 'Electronics' started by lukem, Feb 22, 2011.

  1. lukem

    lukem New Member

    Messages:
    8
    Joined:
    Oct 10, 2010
    Hi folks.
    The radiator fan of my B170 is now permanently running, which has been the same for the last week or so. Doesn't matter if engine is cold or hot.

    I've checked fuses - look OK, I've re-earthed the wires I can see, I've cleaned and WD40'd the large blue fan plug and pushed and prodded other bits. Coolant looks OK although I'll recheck this tonight when I have access to the car.

    Any ideas?

    Thanks for any help!
     
  2. OP
    OP
    lukem

    lukem New Member

    Messages:
    8
    Joined:
    Oct 10, 2010
    er...this is not solved. and can't see how to edit OP. computer at work is painfully slow. help? mods?
     
  3. npuk

    npuk Hardcore MB Enthusiast

    Messages:
    4,239
    Joined:
    Nov 12, 2009
    Location:
    London
    Car:
    A180 CDI Avantgarde SE (2008)
    Click thread tools button > mark thread as unsolved.

    Could be a faulty thermostat? Get the car put on STAR.
     
    Last edited: Feb 22, 2011
  4. OP
    OP
    lukem

    lukem New Member

    Messages:
    8
    Joined:
    Oct 10, 2010
    i can get that checked. had assumed it wasn't as it's warming up as normal and maintaining it's normal steady temperature. anything else?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.