Warning message appeared....... “Active Break Assist Function Limited”

JimGreen

Active Member
Joined
Jan 5, 2016
Messages
316
Location
Kingston Upon Hull
Car
2018 W205 C63 AMG + 2017 Mini Cooper (John Cooper Works) + 2015 Honda Fireblade
2018 C63 (W205) There I was, driving on the M62 and sat at about the legal limit (Genuinely) when suddenly the following message pops up I’m my dash “Active Break Assist Functions Limited” and the car suddenly starts slowing down to the point I have to pull into the hard shoulder where the engine stops !!!!! I restart the car with no problem, but the engine warning light is on, I pull away and the car drives normally for another ten miles, before the same thing happens again, I manage to limp into a service road. I leave the car for about ten minutes and inspect under the bonnet and everything looks fine, normal temp and oil pressure, I thought maybe the rain had caused the fault as it was heavy at times, it was just raining, not a storm.

I started the engine again and this time the engine warning light went off as normal and the car performed perfectly, I arrived at work hoping it was just a glitch and continue my days work.

Finish my days work and start my drive home, no rain and the car performing as normal. Then thirty miles down the road and the same fault again, left the car for ten minutes and she restarts perfectly, engine warning light goes out as normal and gets me home with no further issues.

Anyone had the same happen, now I have no confidence in taking it onto a motorway at rush hour with no hard shoulder !!!

I read that this could be the result of a dirty distance sensor, but I’m not sure what sensor it’s referring too, or where they’re located. The car was clean, not dirty, so not due to dirt covering something.
 
Last edited:

unimog

Active Member
SUPPORTER
Joined
Oct 24, 2015
Messages
563
Location
Derbyshire
Car
W203 C350, AMG GT63s Coupe 4dr
You recently changed your front grille, I would start with looking at the distronic module at the front of car and check the plugs for water ingress.

Do you have a code reader/scanner tool? be helpful to know what codes it has thrown up. iCarsoft MB V2.0 scanners are about 140 quid on their ebay shop.

Other than that, has the car had a recent windscreen repair or replacement? There is a camera at the top of the screen for reading traffic signs and detecting collison obstacles in front of you, these need to be properly calibrated after glass replacement by the dealer.
 
OP
OP
JimGreen

JimGreen

Active Member
Joined
Jan 5, 2016
Messages
316
Location
Kingston Upon Hull
Car
2018 W205 C63 AMG + 2017 Mini Cooper (John Cooper Works) + 2015 Honda Fireblade
Front screen is definitely original, good point about checking the distronic module. Is this the one that sits behind the drivers side front wheel arch ????
 
OP
OP
JimGreen

JimGreen

Active Member
Joined
Jan 5, 2016
Messages
316
Location
Kingston Upon Hull
Car
2018 W205 C63 AMG + 2017 Mini Cooper (John Cooper Works) + 2015 Honda Fireblade
Well, I checked the two connections that go to the front bumper, one is on the nearside which i believe is the outside tempreture sensor and the other connection is a multi plug on the drivers side just infront of the front wheel (Behind the wheel arch liner). Both are nice and dry and fitted correctly.

I need to work out where the brake "Active Brake Assist" sensor is............... does it take its information from the parking sensors, or what appears to be a camera located at the top of the windscreen, or a combination of both ????

There are no other modules i can see, behind the grill or anywhere else ...................
 

DoberMan

Active Member
SUPPORTER
Joined
Nov 7, 2017
Messages
795
Location
Bucks
Car
All gone now.E 220 Convertible, 2x190E, 2xC180, 1xB180 sport.
Isn't the sensor part of the Star badge on the grill?
 
OP
OP
JimGreen

JimGreen

Active Member
Joined
Jan 5, 2016
Messages
316
Location
Kingston Upon Hull
Car
2018 W205 C63 AMG + 2017 Mini Cooper (John Cooper Works) + 2015 Honda Fireblade
Yep, at the top of the windscreen, nothing behind the STAR on the grill.
 

Jobsworth

Active Member
Joined
Sep 23, 2018
Messages
288
Location
Horsham
Car
One or two...
Has the car had any engine remapping carried out?
Don’t worry, I’ve done some stalking and you have!
I’ve seen this before. It’s very likely they have missed the adjustment of a torque monitoring threshold. Its a hidden one, and easily missed on 2017 and newer models. It won’t show itself for a few weeks, but then its there every fifty or so miles. You’ll find a code in the engine ecu for “torque threshold exceeded”. I’ve seen it twice now. Your tuner can fix it. I’m 99% certain this is your problem
 
OP
OP
JimGreen

JimGreen

Active Member
Joined
Jan 5, 2016
Messages
316
Location
Kingston Upon Hull
Car
2018 W205 C63 AMG + 2017 Mini Cooper (John Cooper Works) + 2015 Honda Fireblade
Many Thanks Jobsworth 👍👍👍
 

Users who are viewing this thread

Top Bottom