Windows Installer (from IT Dummy)

l5foye

Active Member
Joined
Jun 16, 2003
Messages
837
Location
N.Ireland
Car
ML 300CDI
When I start up the pc (windows xp professional), Windows Installer box opens up and tries to install JASC Photo Album 5 (already installed by those kind people at Dell) Cancel has to be pressed for about 6 times before it lets me proceed. The Add/Remove facility will not allow me to remove the JASC programmes (no doubt due to the way Dell have installed it)
Is this Windows Installer behaving like this because of a virus? I use AVG which gives the all clear.
Any help/advice will be greatly appreciated.
 

GrahamC230K

MB Enthusiast
Joined
Jul 14, 2002
Messages
9,755
Car
Audi A3 & S4 quattro
Windows Installer might be repairing the install or trying to install an advertised application. Check your event log, it will give you more idea what is happening. I presume you have let it finish once?

When you say "The Add/Remove facility will not allow me to remove the JASC programmes ", what do you mean exactly?
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,392
Car
Lexus RC300h F-Sport 2019
Sometimes these programs are installed by the supplier (Dell) but have not been initialised. Windows Installer is trying to complete the job and you wont be able to un-install the program (even though it appears in the Add/Remove" listing) until it has been fully initialised.

I had this with a couple of Packard Bell apps..
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,323
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
Hmm .. I removed the JASC software from my Dell (also running XP Pro) without any difficulty. Pretty sure I just did it via add/remove programs.
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,392
Car
Lexus RC300h F-Sport 2019
Hmm .. I removed the JASC software from my Dell (also running XP Pro) without any difficulty. Pretty sure I just did it via add/remove programs.
A fully initialised app? (i.e. installed and loaded?)
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,323
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
I'm pretty sure it was fully installed.

I took off quite a bit of stuff as soon as I got the machine e.g.

MS Works (I already had Office)
JASC Photo Album (I already had Paint Shop Pro)
McAfee(?) (I already had Norton)
AOL

... and probably some other things I've forgotten.
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,392
Car
Lexus RC300h F-Sport 2019
I think the OP has not yet fully installed the JASC software, which is why he can't un-install it..
 
OP
OP
L

l5foye

Active Member
Joined
Jun 16, 2003
Messages
837
Location
N.Ireland
Car
ML 300CDI
Thanks for the replies.
The JASC programme is fully installed (all 120 mb of it!)
The Add/Remove facility in control panel reports a fatal error when I go to remove JASC.
 

GrahamC230K

MB Enthusiast
Joined
Jul 14, 2002
Messages
9,755
Car
Audi A3 & S4 quattro
Application Event Log (sure it must be there still in Vista). Confirm if when it runs it is performing a repair or not. MAy also be a clue as to why it is failing. Does it fail for all users of the laptop or just one? Have you tried loogin in with a different user account?

You really want to cure this properly, not use an alternative uninstall program as an advertised MSI can have a lot of registry entries and I don't trust anything but Windows Installer to remove them.
 
Last edited:

GrahamC230K

MB Enthusiast
Joined
Jul 14, 2002
Messages
9,755
Car
Audi A3 & S4 quattro
Windows Installer is not something you want to mess with with a third party application unless you have to.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom