Won't start, all warning lights on. Circuit 30g?

Page may contain affiliate links. Please see terms for details.
Joined
May 14, 2012
Messages
33
Location
Kilmarnock
Car
E280 CDi Sport
Hi. I have a problem with a w211 220cdi 2007. Out of the blue I've had a problem with warning lights and starting when hot.
The problems are abs lights come on along with most of the engine warning lights, Speedo stops working, car sticks in park or drive if trying reverse. If you turn off the engine it won't crank for 5 to 10mins.
I have plugged a Carly in and it shows a problem with the 30g circuit saying it is under voltage. Is looks like it's a relay issue which isn't closing over to allow the car to reset which in turns throwing up.the fault codes. However I cannot find anything for a fix online and I have no idea where the 30g relay would be - loads of references to it but no locations.
Please can anyone help?
 
30 is permanent live. If it says under voltage, what is the battery voltage?
 
30 is permanent live. If it says under voltage, what is the battery voltage?
Thanks for.replying. I have checked and says <10.5v.
Could this be a battery fault?
 
Yes. Definitely. I would get it tested. It should be around 12 volts, ideally 12.6. 👍🏻👍🏻👍🏻
Might be worth getting the charging tested at the same time.
Thanks for your help
Fitted a new battery and all appears to be sorted.
Can't complain about the old battery, it's the original Mercedes one from new.
 
  • Like
Reactions: Ted

Users who are viewing this thread

Back
Top Bottom