Xenon headlights not adjusting level

Discussion in 'Electronics' started by trainer, Apr 20, 2012.

  1. trainer

    trainer MB Enthusiast

    Messages:
    1,144
    Joined:
    Dec 27, 2007
    Location:
    Staffordshire
    Car:
    C32 AMG - Sold October 2013
    Hi,

    I turned left sharply earlier today and hear a loud clunk. There were no feelings of instability afterwards and no loud noises.

    However this evening the Xenon lights did not level when I switched them on and remained on a 'short' beam.

    Any ideas
     
  2. andy27168

    andy27168 MB Enthusiast

    Messages:
    4,401
    Joined:
    Nov 27, 2004
    Location:
    Southampton
    Car:
    1997 C230K, 1999 C43/55 AMG
    Hi,
    Sounds like one of the suspension atitude sensor rods have snapped, there fitted to the drivers side front and rear suspension, if it is just a link arm gone they are quite cheap to replace, though you will have to adjust the rod to the same length as the snapped one.
    It also could be the fact that a suspension spring has snapped but if the car seems to be driving ok like you say then its unlikely to be this.
     
    1 person likes this.
  3. OP
    OP
    trainer

    trainer MB Enthusiast

    Messages:
    1,144
    Joined:
    Dec 27, 2007
    Location:
    Staffordshire
    Car:
    C32 AMG - Sold October 2013
    Hi,

    Thanks for the response. I will have a look this morning and see if it is any of the things you have suggested.

    Have a good day
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.