Bought Dynavin, not powering up, help

Discussion in 'Interior' started by CLSMark, May 6, 2017.

  1. CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg
    I'm fairly competent when it comes to installing, but I have a feeling there is part of the harness missing. Could somebody confirm my theory please

    [​IMG]

    [​IMG]


    Sent from my iPhone using Tapatalk
     
  2. l5foye

    l5foye Hardcore MB Enthusiast

    Messages:
    804
    Joined:
    Jun 16, 2003
    Location:
    N.Ireland
    Car:
    ML 300CDI
    There should be an online wiring diagram depending on the model of Dynavin you have. The part you are holding in 2nd photo looks like the can interface. Sorry I cannot be of more help.
     
  3. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg


    Yeh it is the can interface, just seems odds that it has yellow and black power going to it, and also an empty plug socket.


    Sent from my iPhone using Tapatalk
     
  4. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg
    Bump, anyone?


    Sent using a tin can on the end of a string
     
  5. mikeb40

    mikeb40 New Member

    Messages:
    2
    Joined:
    Sep 8, 2012
    Hi,
    If it's anything like the 'connects2' canbus adaptors then that missing connector is for the steering wheel remote. These are available from most car audio shops.

    Just guessing, based on my 'connects2' adaptor. From the Quadlock plug connected to the car loom going to the adaptor, the red & white twisted pair look like the canbus input, the yellow permanent live, black ground. From the adaptor to the Dynavin unit ISO plug, the red will possibly be switched live controlled by the adaptor. You may have other wires for lights, reverse, handbrake, and canbus.

    Please don't take this as fact, it's only an educated guess as I'm not familiar with Dynavin wiring. So please check with a multi-meter first after unplugging the Dynavin. Twisted pair wires will usually be for the canbus network signal, do not fiddle with these.
     
  6. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg


    Thanks mate, I've sent it back to the seller. He was a bit of a **** about it. Reckons I haven't wired it up correctly.


    Sent using a tin can on the end of a string
     
  7. clk320x

    clk320x MB Club Veteran

    Messages:
    9,344
    Joined:
    Sep 27, 2016
    Location:
    East Midlands
    Car:
    W211 E320 CDI - W212 E250 CDI
    Told you they were hit and miss :)
     
  8. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg


    On 2nd headunit now. Same issue. Sending me a different harness, that doesn't work I'm giving up


    Sent using a tin can on the end of a string
     
  9. brucemillar

    brucemillar MB Club Veteran

    Messages:
    8,663
    Joined:
    Nov 18, 2010
    Location:
    Next Door to Alice - 25 'kin years now
    Car:
    C55 AMG Wagon - W124 300te 4matic Wagon - BMW 4.8is X5 E53 - SWB Pajero 3.5 V6 24v
    When you say 'does'nt work' what is actually happening?

    Mercs tend to use a different switched live from most 'off the shelf' head units. So you have to swap the switched live, from the car, over. 1 is normally capped from the factory.

    Apologies if I am talking nonsense.
     
  10. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg


    Not at all, I get you.

    Not powering on at all


    Sent using a tin can on the end of a string
     
  11. OP
    OP
    CLSMark

    CLSMark Banned

    Messages:
    1,262
    Joined:
    Feb 25, 2017
    Location:
    Hampshire via Glasgow
    Car:
    Volkswagen Touareg
    [​IMG]

    Problem solved ( Different harness )

    Might not be to everybody's taste, but it looks OEM. Has CarPlay. And sounds amazing


    Sent using a tin can on the end of a string
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.