OTA map update

Page may contain affiliate links. Please see terms for details.

TheAbbot

New Member
Joined
Apr 27, 2023
Messages
16
Location
hampshire
Car
E 350 D 4ma convertible
Had a notification that an updated map was winging its way down to the car, started off great but now its stuck on 98% and has been for the last 6 days. Anybody have any ideas how to get it to install the last 2%. It says its installing with the rotating symbol but nothing appears to be happening!!

Thanks

Mike
 
Had a notification that an updated map was winging its way down to the car, started off great but now its stuck on 98% and has been for the last 6 days. Anybody have any ideas how to get it to install the last 2%. It says its installing with the rotating symbol but nothing appears to be happening!!

Thanks

Mike
Can you delete the update?
 
Try downloading the update onto an SD card or USB stick (via the Mercedes Me web portal) and installing from there.

I actually do all my updates that way now rather than waiting for the OTA update.
 
I don't think I can stop the update, well no one on the internet knows how to, that I've found. I will try the downloading to usb stick and see if that works,

Thanks
 
Got in the car today to go shopping, parked up, and when I came out and started the car there was a message saying "Multimedia has been updated" strange why it took so long to finish, it has so never mind.

Thanks
 
Got in the car today to go shopping, parked up, and when I came out and started the car there was a message saying "Multimedia has been updated" strange why it took so long to finish, it has so never mind.

Thanks

Maybe it was watching this thread ... AI is everywhere now :D
 
...AI is nowhere near my "ME" account. Got a message a few weeks ago that Map updates Version 26 is now available.
OTA for my home region but ME suggested manual download for other regions.

So I logged in, selected the entire western continental Europe and downloaded the map data. It did take well over one hour
to save it on a USB-stick. Then inserted the stick in one of the USB-connectors in my car. The upload started which also
took an hour to complete. According the my car, all went well.

But - "ME" reported that the download failed to download. According to the system tab in my car, the maps are updated but "ME"
thinks otherwise. Trying to repeat the download fails. No further regions can be selected and no download can be repeated.

Inserting the stick one more time, the car first reports that a new version is available but once the process
starts, it immedeately aborts with an error message. "Wrong version"

I have filed a service request for this at MB customer service a week ago. They are trying to find the cause but so far
no reply.

Other OTA updates have taken place during night time. At least 4 of them including maps and system software
but this time, the map update failed.
 
...AI is nowhere near my "ME" account. Got a message a few weeks ago that Map updates Version 26 is now available.
OTA for my home region but ME suggested manual download for other regions.

Certainly on my car you *only* get OTA updates for your home region e.g. UK. We drive to Germany now and again so I always do a manual download for all of Europe (including the UK map) ... I use a high speed SD card for this rather than a USB stick. The download onto that from the Me Portal takes longer than applying the update in the car. Apart from taking a while I've never had any problems - hope you get yours sorted out.
 
  • Like
Reactions: Uky

Users who are viewing this thread

Back
Top Bottom