w210 e300td heater always blowing cold air

Velo96

New Member
Joined
Jun 16, 2021
Messages
18
Location
co.fermanagh NI
Car
mercedes w210 E300TD
hi i have an issue with the heater system always blowing cold air i have replaced thermostat and cleaned the duo valve but issue still here the motor seems to work as blowing cold air, i noticed if i turn the dial from hot to cold the sound would get louder but still cold air. anyone have a similar problem, where to look next? heater resistor?
as winter coming up and it wil be a cold ride.
 
OP
OP
Velo96

Velo96

New Member
Joined
Jun 16, 2021
Messages
18
Location
co.fermanagh NI
Car
mercedes w210 E300TD
I am unsure but the duo valve does get hot and and the 2 wee valves moves up and down freely
 

design guru

Active Member
Joined
Feb 28, 2004
Messages
460
Location
Hampshire
Car
2001 W220 Mercedes S320cdi & 2001 W208 CLK230K (SORN since 2008)
1 + Duo Valve. Always goes at this time of the year.
 
OP
OP
Velo96

Velo96

New Member
Joined
Jun 16, 2021
Messages
18
Location
co.fermanagh NI
Car
mercedes w210 E300TD
I've just took duo valve apart again give it a good clean now there is hot air but only when I'm driving or reving on idle it blow cold air, I will order a new duo valve, in mean time is there a way to bleed the system?
 

johnsco

MB Enthusiast
SUPPORTER
Joined
Nov 22, 2008
Messages
2,439
Location
Leeds, West Yorkshire
Car
E280CDI SPORTS ESTATE and C200 KOMPRESSOR SE Coupe Auto (1.8 lit petrol)
I've just took duo valve apart again give it a good clean now there is hot air but only when I'm driving or reving on idle it blow cold air, I will order a new duo valve, in mean time is there a way to bleed the system?
I used to run a E300TD.
When I changed the coolant, I just ran it.
It bled itself - But I had to top it up a couple of times.
 

mersum1es

MB Enthusiast
Joined
Aug 9, 2012
Messages
1,799
Location
Finland
Car
W212, C219
Do you have separate electric water pump (some models do have), check if its broken.
 

wrdcc01

Active Member
Joined
Mar 23, 2008
Messages
229
Location
Crystal Palace
Car
1994 W124 E280 saloon M104.942 4s-auto, 72 Hillman Hunter GLS, 71 GPO Minor LCV.
While you're going through all the above it might be worth giving the cooling and heating system a back flush (don't forget to set the heater at max with the ignition on and either remove the thermostat or flush rad' separately) then filling with water to test if it's all working ok. Drain and refill with coolant (the same day in case it hits 0 overnight). Should it still only be heating when revved, you could be looking at a new water pump.
 

Users who are viewing this thread

Top Bottom