OVP Experience

E200CT

New Member
Joined
Jun 3, 2011
Messages
16
Location
Chester
Car
2005 CLK320 Cabriolet
Sorry to resurrect this age old topic as I'm relatively new to these ere forums and thought I would give others who have a problem with their abs system light some information on how I fixed it.
Back in Feb, my abs light came on and I thought oh MOT failure if I can't suss out the problem.
So I searched and read as many topics on the subject as I could to get a better understanding of what to do, so I systematically went through all the things to check, firstly bad running thought of the wiring loom and yes corroded, but I have managed to repair it as much as I could by re wrapping the insulation as far as I could without doing to much more damage, at some point in the future, I intend to take it off and re wrap the insulation properly as replacing it isn't an option.
Abs light still on, next I took out the wheel sensors, and they were covered in metal fur on the magnets, ah that must be what's wrong, wrong again, light was still on.
In the meantime took off the OVP relay and opened it up and did the re soldering bit, but after refitting it the light still wouldn't go out, I did all of the above work waiting for a new to me OVP from the States, couldn't find one over here, and also ordered a new brake light switch cause apparently that can cause an abs fault as well.
Well the new ovp came in the post today, the new version with two fuses on the top, the other must have been OEM with a single fuse, fitted the new ovp and voilà, the light was still on but went out after I started the car, problem solved, didn't need the brake light switch but I have that as a spare.
So I now have a sweet running car again no misfiring ticks over fantastic, and all power restored.
So the moral of my tail is, check the ovp first because that is more than likely the cause, so much is controlled by that little gizmo it's unbelievable. if someone says its the OVP then it probably is.

My car for those interested is 1994 E200 W124
 

GP801

MB Enthusiast
SUPPORTER
Joined
Jun 18, 2010
Messages
3,086
Location
Sussex and Tuscany
Car
2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
Dont know about from the USA but a new one from main dealer in the uk for our 124 280 was £65 + VAT
 
OP
OP
E200CT

E200CT

New Member
Joined
Jun 3, 2011
Messages
16
Location
Chester
Car
2005 CLK320 Cabriolet
I paid $28 for the OVP + pp of $13 It was a used one not new.

Total about £23.
 

Users who are viewing this thread

Top Bottom