Becker Audio replacement

Discussion in 'Electronics' started by kkbuk, Jan 6, 2009.

  1. kkbuk

    kkbuk New Member

    Messages:
    3
    Joined:
    Jan 6, 2009
    Location:
    Mazarron, Spain
    Car:
    Mercedes S500
    Can anyone advise me how to connect a modern stereo unit in place of the Becker unit (with Bose amplifiers and speakers) in my S-Class 500, circa 1993?
     
  2. Bobby Dazzler

    Bobby Dazzler MB Club Veteran

    Messages:
    15,344
    Joined:
    Jan 21, 2005
    Location:
    Mittel England
    Car:
    ML AMG-line Black Series
    Welcome to MBClub.

    No idea on specifics, but adapters and harnesses are usually available with which you can connect any type of head unit to any type of loom.

    Being a 1993, I'd be surprised if your loom doesn't readily accept a DIN ISO connector. For example:

    http://www.audio-10.com/94.html
     
  3. NW_Merc

    NW_Merc Banned

    Messages:
    5,918
    Joined:
    Sep 3, 2005
    Location:
    Over here, sometimes over there
    Car:
    1994 Mercedes C180 classic
  4. OP
    OP
    kkbuk

    kkbuk New Member

    Messages:
    3
    Joined:
    Jan 6, 2009
    Location:
    Mazarron, Spain
    Car:
    Mercedes S500
    Thanks for the info, unfortunately it isnt just a straight swap, I wish it was!
     
  5. speedevilus

    speedevilus Active Member

    Messages:
    75
    Joined:
    Dec 6, 2008
    Hi Mate,
    That is exactly what io am doing and there is a connector for amplifird cars. depends on the headunit's make there is definately a ISO conntor.
     
  6. vilooire

    vilooire New Member

    Messages:
    1
    Joined:
    Aug 18, 2017
    Car:
    W 203
    Sorry, I have a w203 200 cdi and bought an Android radio. and I have some problems
    I tried to get answers from some professionals but I think the different opinions did not lead me to anything, so I repeat the question of the Android radio (brand Isudar) that I have installed but not with total satisfaction and that is due to poor reception (I assume some antenna connection.
    So: In the photo below is the wiring that fed the previous radio (Audio 10 - Becker). From what I've seen, on the net the pins that contain the connection are: 2,3,4,5 and 8. The plug in the Android radio, where that link has the same five pins but in different order: 4,5,6,7 and 8. In turn the Android radio only takes advantage of pins 4 and 8, joining, two of the other three that are connected to nothing but isolating the 5 and which has an "ANT" ID.
    The installed radio (Android) has everything working (with the defects related to the commands on the steering wheel and already described), but the worst, for now is the capture of the radio that is constantly looking for signal.
    Since the insulated wire marked "ANT" is not connected to anything, I assume that the antenna does not have amplification and so I ask who knows

    What are the pins 2, 3 (a 5 is described as ... for antenna and the others are the connection to the battery and the mass);
    Pin 5 passes current to the radio or only receives current when the radio is connected to the antenna amplifier.

    Advance grateful
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.