CarPlay Becker Module Displaying ‘No Navigation’

Page may contain affiliate links. Please see terms for details.

Siwel

New Member
Joined
Oct 5, 2023
Messages
4
Location
Basingstoke
Car
C class
Hi All, I’m hoping someone has had a similar experience to me and could help. I have a c220 2013 using NTG 4.5. I was looking for a car play solution and came across the following on Amazon: https://www.amazon.co.uk/dp/B09993XC87?ref_=cm_sw_r_apin_dp_A8BJ9WQ49VE8W9HQX3ZV

This is meant to be a plug and play module that uses the Becker slot in the glove box.

I have plugged this into the car and connected directly to the box, my phone connects perfectly and is outputting audio through the aux. The idea is that when you click the ‘NAVI’ button on the center console, the display will then use the module to give me CarPlay. I just get faced with a ‘No Navigation’ message. I know the module is working and getting power but it doesn't seem to communicate with the car.

I have tried 2 different modules and I have tried to clean the Becker port with rubbing alcohol but nothing wants to work. I have noticed on videos and picture that other people have the ‘Navi’ option on their system already, mine does not have this, I can only access this by clicking the button, does this mean I need to have something enabled or an update. Any help would be appreciated :)

Lewis
 

Users who are viewing this thread

Back
Top Bottom