W204 Becker or COMAND confused?

Page may contain affiliate links. Please see terms for details.
so after several months they finally sorted the other issues and I now have the car back. They 'reset' the nav unit, and it is now showing the map screen ok... I downloaded the Manual_MAP_PILOT_V2_5_ECE_en_GB.pdf previously when trying to get the navi to work.
My problem now is 'how do you access the menu?', when selecting NAVI it simply shows where I am on the map - I've tried pressing all sorts of buttons and the rotary control, but nothing seems to change? it does show the position moving on the map when driving, as well as numer of sata;lites available. sometimes the TMC status lights up; but I have not found how to get back to the menu...
If I select NAVI from the steering wheel buttons, it still only shows 'activating navigation' ???
1683042025944.png
see original post image for comparison where menu was shown, but frozen
 
OK; so just been out and done a reset on the Becker again, and it re-started finally giving the menu ok... been round the menu's and then selected the map. Now it seems ok, I can get back to the menu ok and scroll around with the rotary dial... so no idea why it wouldn't before. Hope I don't have to press the reset button all the time! `¬)
Haven't tried setting a route yet, I'll have a further play and see what happens... assuming it still works when I go back to the car when I get a few minutes... 🤪
 
You can replace the Becker module in the glovebox with one that will give you Android Auto and Carplay.

 
Can't see why not, drop them a message
 

Users who are viewing this thread

Back
Top Bottom